summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2007-07-07 14:05:23 +0000
committerGeorge Shapovalov <george@gentoo.org>2007-07-07 14:05:23 +0000
commit32b6d32484d44ad267b94c3ccff393b1f205492b (patch)
tree47244865db83911f9268439588cdd1b235b3746e /dev-util
parentWe need fixed pysqlite-2.3.4-r1 for tr_TR.utf8 locale. (diff)
downloadgentoo-2-32b6d32484d44ad267b94c3ccff393b1f205492b.tar.gz
gentoo-2-32b6d32484d44ad267b94c3ccff393b1f205492b.tar.bz2
gentoo-2-32b6d32484d44ad267b94c3ccff393b1f205492b.zip
added changes to make ctags coexist with the (x)emacs versions via eselect-emacs (the ctags module). Resolving #29398.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ctags/ChangeLog8
-rw-r--r--dev-util/ctags/ctags-5.6-r3.ebuild65
-rw-r--r--dev-util/ctags/files/digest-ctags-5.6-r36
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-util/ctags/ChangeLog b/dev-util/ctags/ChangeLog
index 682f94e1eaa8..bab63aff5a3f 100644
--- a/dev-util/ctags/ChangeLog
+++ b/dev-util/ctags/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ctags
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.58 2007/06/26 20:06:48 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.59 2007/07/07 14:05:23 george Exp $
+
+*ctags-5.6-r3 (07 Jul 2007)
+
+ 07 Jul 2007; George Shapovalov <george@gentoo.org> +ctags-5.6-r3.ebuild:
+ added changes to make ctags coexist with the (x)emacs versions via
+ eselect-emacs (the ctags module). Resolving #29398.
*ctags-5.6-r2 (26 Jun 2007)
diff --git a/dev-util/ctags/ctags-5.6-r3.ebuild b/dev-util/ctags/ctags-5.6-r3.ebuild
new file mode 100644
index 000000000000..4d7237a13860
--- /dev/null
+++ b/dev-util/ctags/ctags-5.6-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ctags-5.6-r3.ebuild,v 1.1 2007/07/07 14:05:23 george Exp $
+
+inherit eutils
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/ctags/${P}.tar.gz
+ mirror://sourceforge/gnuada/ctags-ada-mode-4.3.3.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ada"
+
+DEPEND=">=app-admin/eselect-emacs-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-ebuilds.patch"
+ #epatch "${FILESDIR}/${P}-haskell.patch"
+ #epatch "${FILESDIR}/${P}-objc.patch"
+ epatch "${FILESDIR}/${P}-php5.patch"
+
+ # enabling Ada support
+ if use ada; then
+ cp ${WORKDIR}/ctags-ada-mode-4.3.3/ada.c ${S}
+ epatch "${FILESDIR}/${PN}-ada.patch"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv ${D}/usr/bin/{ctags,exuberant-ctags}
+ mv ${D}/usr/share/man/man1/{ctags,exuberant-ctags}.1
+
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
+
diff --git a/dev-util/ctags/files/digest-ctags-5.6-r3 b/dev-util/ctags/files/digest-ctags-5.6-r3
new file mode 100644
index 000000000000..6146817cc6bc
--- /dev/null
+++ b/dev-util/ctags/files/digest-ctags-5.6-r3
@@ -0,0 +1,6 @@
+MD5 9026a6c6950751bc4fd1be37e8a2070f ctags-5.6.tar.gz 267019
+RMD160 9221bcc105f302b6e05f599914f5d4e24cda62f0 ctags-5.6.tar.gz 267019
+SHA256 55c0693845644735f76242fa717efd92d9cb99543f7a7fa65d63bdd083c4eb95 ctags-5.6.tar.gz 267019
+MD5 d38eb534710f19639be9940ebcd7579f ctags-ada-mode-4.3.3.tar.bz2 14086
+RMD160 55f777901443e3f2dc990f05a2a866892d38cc18 ctags-ada-mode-4.3.3.tar.bz2 14086
+SHA256 f0ef3ad82654ed5fe4d4e12ec64c7988d7cd40cd7dc67c89eaac06869c5a36fa ctags-ada-mode-4.3.3.tar.bz2 14086