summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2014-12-01 06:39:59 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2014-12-01 06:39:59 +0000
commit3f7483fa0f8e8fc5ed6b91fd678db824d9553b1d (patch)
tree68fa0093269f6b15d43a809bb0a12ed246d4c85d /dev-util
parentVersion bump. (diff)
downloadgentoo-2-3f7483fa0f8e8fc5ed6b91fd678db824d9553b1d.tar.gz
gentoo-2-3f7483fa0f8e8fc5ed6b91fd678db824d9553b1d.tar.bz2
gentoo-2-3f7483fa0f8e8fc5ed6b91fd678db824d9553b1d.zip
Version bump to 1.0.0 per bug 530754
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog9
-rw-r--r--dev-util/oprofile/files/oprofile-1.0.0-athlon.patch20
-rw-r--r--dev-util/oprofile/oprofile-1.0.0.ebuild70
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 1fb32f72a3e4..7243a9fac41a 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.96 2014/11/16 12:42:25 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.97 2014/12/01 06:39:59 bircoph Exp $
+
+*oprofile-1.0.0 (01 Dec 2014)
+
+ 01 Dec 2014; Andrew Savchenko <bircoph@gentoo.org> +oprofile-1.0.0.ebuild,
+ +files/oprofile-1.0.0-athlon.patch:
+ Version bump to 1.0.0, see bug 530754.
+ Fix CPU detection for Athlon systems.
16 Nov 2014; Andrew Savchenko <bircoph@gentoo.org> metadata.xml:
Add myself to maintainers
diff --git a/dev-util/oprofile/files/oprofile-1.0.0-athlon.patch b/dev-util/oprofile/files/oprofile-1.0.0-athlon.patch
new file mode 100644
index 000000000000..3a6db3bd72e5
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.0.0-athlon.patch
@@ -0,0 +1,20 @@
+Fix AMD Athlon CPU family recognition.
+See upstream bug 275 for details:
+https://sourceforge.net/p/oprofile/bugs/275/
+--- oprofile-1.0.0/libop/op_cpu_type.c.orig 2014-09-12 18:39:47.000000000 +0400
++++ oprofile-1.0.0/libop/op_cpu_type.c 2014-11-30 18:29:00.328342552 +0300
+@@ -538,10 +538,13 @@
+ family = cpu_family(eax);
+
+ /* These family does not exist in the past.*/
+- if (family < 0x0f || family == 0x13)
++ if (family < 0x0f && family != 0x6 || family == 0x13)
+ return ret;
+
+ switch (family) {
++ case 0x6:
++ ret = op_get_cpu_number("i386/athlon");
++ break;
+ case 0x0f:
+ ret = op_get_cpu_number("x86-64/hammer");
+ break;
diff --git a/dev-util/oprofile/oprofile-1.0.0.ebuild b/dev-util/oprofile/oprofile-1.0.0.ebuild
new file mode 100644
index 000000000000..46aed12d94c1
--- /dev/null
+++ b/dev-util/oprofile/oprofile-1.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-1.0.0.ebuild,v 1.1 2014/12/01 06:39:59 bircoph Exp $
+
+EAPI="5"
+inherit eutils java-pkg-opt-2 linux-info multilib user
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://${PN}.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java pch"
+
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ java? ( >=virtual/jdk-1.5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="PERF_EVENTS"
+ERROR_PERF_EVENTS="CONFIG_PERF_EVENTS is mandatory for ${PN} to work."
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! kernel_is -ge 2 6 ; then
+ echo
+ elog "Support for kernels before 2.6 has been dropped in ${PN}-0.9.8."
+ echo
+ fi
+
+ # Required for JIT support, see README_PACKAGERS
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+
+ use java && java-pkg_init
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-athlon.patch"
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable pch) \
+ $(use_with java java ${JAVA_HOME})
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldir="/usr/share/doc/${PF}" install
+
+ dodoc ChangeLog* README TODO
+ echo "LDPATH=${PREFIX}/usr/$(get_libdir)/${PN}" > "${T}/10${PN}"
+ doenvd "${T}/10${PN}"
+}
+
+pkg_postinst() {
+ echo
+ elog "Starting from ${PN}-1.0.0 opcontrol was removed, use operf instead."
+ elog "CONFIG_OPROFILE is no longer used, you may remove it from your kernels."
+ elog "Please read manpages and this html doc:"
+ elog " /usr/share/doc/${PF}/${PN}.html"
+ echo
+}