summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2008-08-18 21:03:52 +0000
committerHarald van Dijk <truedfx@gentoo.org>2008-08-18 21:03:52 +0000
commit4418e1e8192e62cff25b4d19d853375f705b1758 (patch)
treef892e341846ed30b27df218bd136a570443e9437 /dev-util
parentInitial import (diff)
downloadgentoo-2-4418e1e8192e62cff25b4d19d853375f705b1758.tar.gz
gentoo-2-4418e1e8192e62cff25b4d19d853375f705b1758.tar.bz2
gentoo-2-4418e1e8192e62cff25b4d19d853375f705b1758.zip
Version bump (#234671)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dialog/ChangeLog8
-rw-r--r--dev-util/dialog/dialog-1.1.20080727.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-util/dialog/ChangeLog b/dev-util/dialog/ChangeLog
index 354b434db2f7..ae9f2292031d 100644
--- a/dev-util/dialog/ChangeLog
+++ b/dev-util/dialog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/dialog
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.112 2008/06/02 15:36:10 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.113 2008/08/18 21:03:52 truedfx Exp $
+
+*dialog-1.1.20080727 (18 Aug 2008)
+
+ 18 Aug 2008; Harald van Dijk <truedfx@gentoo.org>
+ +dialog-1.1.20080727.ebuild:
+ Version bump (#234671)
02 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
dialog-1.1.20080316.ebuild:
diff --git a/dev-util/dialog/dialog-1.1.20080727.ebuild b/dev-util/dialog/dialog-1.1.20080727.ebuild
new file mode 100644
index 000000000000..93a78d056716
--- /dev/null
+++ b/dev-util/dialog/dialog-1.1.20080727.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.1.20080727.ebuild,v 1.1 2008/08/18 21:03:52 truedfx Exp $
+
+inherit eutils
+
+MY_PV="${PV/1.1./1.1-}"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples nls unicode"
+
+RDEPEND=">=app-shells/bash-2.04-r3
+ >=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "Installing dialog with the unicode flag requires ncurses be"
+ eerror "built with it as well. Please make sure your /etc/make.conf"
+ eerror "or /etc/portage/package.use enables it, and re-install"
+ eerror "ncurses with \`emerge --oneshot sys-libs/ncurses\`."
+ die "Re-emerge ncurses with the unicode flag"
+ fi
+}
+
+src_compile() {
+ use unicode && ncursesw="w"
+ econf $(use_enable nls) \
+ "--with-ncurses${ncursesw}" || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc CHANGES README VERSION
+
+ if use examples; then
+ docinto samples
+ dodoc samples/*
+ fi
+}