summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Seidel <tuxus@gentoo.org>2003-02-16 10:56:48 +0000
committerJan Seidel <tuxus@gentoo.org>2003-02-16 10:56:48 +0000
commit52bb85a4ab6ff3d2e14dd9bd971b9f87c622d64e (patch)
treea91a55a14f84b41db9fbb7a8c446f829ee8aae85 /dev-util
parentversion bump (diff)
downloadgentoo-2-52bb85a4ab6ff3d2e14dd9bd971b9f87c622d64e.tar.gz
gentoo-2-52bb85a4ab6ff3d2e14dd9bd971b9f87c622d64e.tar.bz2
gentoo-2-52bb85a4ab6ff3d2e14dd9bd971b9f87c622d64e.zip
new strace and added mips to keywords
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/files/digest-strace-4.4.931
-rw-r--r--dev-util/strace/files/strace-4.4.93-configure.ac.patch9
-rw-r--r--dev-util/strace/strace-4.4.93.ebuild57
4 files changed, 73 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 0d980b612b22..97ab27b1ac14 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.11 2003/02/14 11:19:22 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.12 2003/02/16 10:56:48 tuxus Exp $
+
+*strace-4.4.93 (16 Feb 2003)
+
+ 16 Feb 2003; Jan Seidel <tuxus@gentoo.org> strace-4.4.93.ebuild :
+ Added mips to keywords
14 Feb 2003; Guy Martin <gmsoft@gentoo.org> strace-4.4-r1.ebuild :
Added -DHPPA for gcc on hppa. Added hppa to keywords.
diff --git a/dev-util/strace/files/digest-strace-4.4.93 b/dev-util/strace/files/digest-strace-4.4.93
new file mode 100644
index 000000000000..61bbcb8fe34e
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.4.93
@@ -0,0 +1 @@
+MD5 7d2df2a1522533cd51feb52eb1de4b76 strace-4.4.93.tar.bz2 361355
diff --git a/dev-util/strace/files/strace-4.4.93-configure.ac.patch b/dev-util/strace/files/strace-4.4.93-configure.ac.patch
new file mode 100644
index 000000000000..e92c52b53a7d
--- /dev/null
+++ b/dev-util/strace/files/strace-4.4.93-configure.ac.patch
@@ -0,0 +1,9 @@
+--- strace/configure.ac.old 2003-01-21 21:29:56.000000000 +0100
++++ strace/configure.ac 2003-04-13 21:45:02.000000000 +0200
+@@ -1,5 +1,5 @@
+ dnl Process this file with autoconf to create configure. Use autoreconf.
+-AC_PREREQ(2.57)
++AC_PREREQ(2.54)
+ AC_INIT([strace],[4.4.93])
+ AC_CONFIG_SRCDIR([strace.c])
+ AM_CONFIG_HEADER([config.h])
diff --git a/dev-util/strace/strace-4.4.93.ebuild b/dev-util/strace/strace-4.4.93.ebuild
new file mode 100644
index 000000000000..230be9e8f3f1
--- /dev/null
+++ b/dev-util/strace/strace-4.4.93.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4.93.ebuild,v 1.1 2003/02/16 10:56:48 tuxus Exp $
+
+# NOTE: For some reason, upstream has changed the naming scheme
+# for the tarballs to something quite lame:
+# strace_version-revision.tar.gz
+# This makes it difficult for us to deal with, because portage
+# is supposed to glean the package version information from the
+# filename of the ebuild. Grr
+# Thus, *MAINTAINER*: change the *revision* in the SRC_URI below
+# by hand. Sorry, couldn't think of a better way.
+# - Jon Nelson, 27 Apr 2002
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A usefull diagnostic, instructional, and debugging tool"
+SRC_URI="mirror://sourceforge/strace/strace-4.4.93.tar.bz2"
+HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa mips"
+
+DEPEND="virtual/glibc >=sys-devel/autoconf-2.54"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # the patch change the autoconf dep to 2.54
+ patch -p1 < ${FILESDIR}/strace-4.4.93-configure.ac.patch || die
+}
+
+src_compile() {
+ # Compile fails with -O3 on but works on x86, sparc untested
+# if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+# if [ -n "${CFLAGS}" ]; then
+# CFLAGS=`echo ${CFLAGS} | sed -e 's:-O3:-O2:'`
+# fi
+# fi
+ # configure is broken by default for sparc and possibly others, regen
+ # from configure.in
+ autoconf
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install () {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace
+ dobin strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+}