summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-31 22:15:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-31 22:15:43 +0000
commit5865bcb77d53c02dd0f7ff08e7d43032afcfa8ca (patch)
treefcf3a83a706d5231ac30b35d4328c1b2c2500be1 /dev-util
parentNon-maintainer commit: Version bump for security bug 282653. Removing unneded... (diff)
downloadgentoo-2-5865bcb77d53c02dd0f7ff08e7d43032afcfa8ca.tar.gz
gentoo-2-5865bcb77d53c02dd0f7ff08e7d43032afcfa8ca.tar.bz2
gentoo-2-5865bcb77d53c02dd0f7ff08e7d43032afcfa8ca.zip
Version bump. Add support for svk.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.3.1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 5c4b54a494e8..f641f7f47802 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.102 2009/07/27 08:47:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.103 2009/08/31 22:15:43 eva Exp $
+
+*meld-1.3.1 (31 Aug 2009)
+
+ 31 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org> +meld-1.3.1.ebuild:
+ Version bump. Add support for svk.
27 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org> -meld-1.2.1.ebuild,
-files/meld-1.2-fr-help-install-fix.patch,
diff --git a/dev-util/meld/meld-1.3.1.ebuild b/dev-util/meld/meld-1.3.1.ebuild
new file mode 100644
index 000000000000..cca4cbc842db
--- /dev/null
+++ b/dev-util/meld/meld-1.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.3.1.ebuild,v 1.1 2009/08/31 22:15:43 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit python gnome2 eutils multilib
+
+DESCRIPTION="A graphical (GNOME 2) diff and merge tool"
+HOMEPAGE="http://meld.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=dev-python/libgnome-python-2.22
+ >=dev-python/gconf-python-2.22
+ >=dev-python/gnome-vfs-python-2.22 )
+ >=dev-python/pygtk-2.8.0
+ >=dev-python/pygobject-2.8"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS NEWS help/ChangeLog"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix the prefix so its not in */local/*
+ sed -e 's:/usr/local:/usr:' \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # let the python eclass handle python objects
+ sed -e '/$(PYTHON) .* .import compileall;/s/\t/&#/g' \
+ -i GNUmakefile || die "sed 3 failed"
+
+ # don't run scrollkeeper (with the wrong path), leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/GNUmakefile || die "sed 4 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/GNUmakefile || die "sed 5 failed"
+ fi
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/meld
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/meld
+}