summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-29 08:04:07 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-29 08:04:07 +0000
commit5e8625fb652c80ec6c89bacaa35334ade576d7f7 (patch)
tree9677765aba13bcb73c4c0f801288eed6ce1b2fd5 /dev-util
parentStable on alpha, bug 551814 (diff)
downloadgentoo-2-5e8625fb652c80ec6c89bacaa35334ade576d7f7.tar.gz
gentoo-2-5e8625fb652c80ec6c89bacaa35334ade576d7f7.tar.bz2
gentoo-2-5e8625fb652c80ec6c89bacaa35334ade576d7f7.zip
Backport patch for /bin/sh -> dash, bug #555360
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/patchelf/ChangeLog6
-rw-r--r--dev-util/patchelf/files/patchelf-0.8-dash.patch28
-rw-r--r--dev-util/patchelf/patchelf-0.8.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-util/patchelf/ChangeLog b/dev-util/patchelf/ChangeLog
index d17586495d39..c5e5b02e4c95 100644
--- a/dev-util/patchelf/ChangeLog
+++ b/dev-util/patchelf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/patchelf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.15 2015/06/24 10:55:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.16 2015/07/29 08:04:07 jlec Exp $
+
+ 29 Jul 2015; Justin Lecher <jlec@gentoo.org> +files/patchelf-0.8-dash.patch,
+ patchelf-0.8.ebuild:
+ Backport patch for /bin/sh -> dash, bug #555360
24 Jun 2015; Agostino Sarubbo <ago@gentoo.org> patchelf-0.8.ebuild:
Stable for ppc, wrt bug #537940
diff --git a/dev-util/patchelf/files/patchelf-0.8-dash.patch b/dev-util/patchelf/files/patchelf-0.8-dash.patch
new file mode 100644
index 000000000000..4210b1c054d0
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-0.8-dash.patch
@@ -0,0 +1,28 @@
+From 3b9e7913a6d14cb09ed91ce8a1110955bda200ef Mon Sep 17 00:00:00 2001
+From: Alexandre Pretyman <alexandre.pretyman@gmail.com>
+Date: Tue, 14 Jul 2015 09:12:38 -0400
+Subject: [PATCH] Change configure.ac from OpenWrt to support Mac OS
+
+This change is from the OpenWrt project, from the URL:
+https://dev.openwrt.org/ticket/18998
+It enables patchelf to sucessfully compile and run under Mac OS and
+keeps compatibility with Linux.
+
+Tested under Mac OS X 10.9.5 and Ubuntu 15.04 to patch a binary of type
+ELF 32-bit LSB executable - the patch fully worked
+
+This patch is credited to Felix Fietkau
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8ca9ad4..69e12de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([patchelf], m4_esyscmd([echo -n $(cat ./version)]))
++AC_INIT([patchelf], m4_esyscmd([printf $(cat ./version)]))
+ AC_CONFIG_SRCDIR([src/patchelf.cc])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall -Werror dist-bzip2 foreign color-tests parallel-tests])
diff --git a/dev-util/patchelf/patchelf-0.8.ebuild b/dev-util/patchelf/patchelf-0.8.ebuild
index f6b234af45ff..abc3d94174ab 100644
--- a/dev-util/patchelf/patchelf-0.8.ebuild
+++ b/dev-util/patchelf/patchelf-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/patchelf-0.8.ebuild,v 1.5 2015/06/24 10:55:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/patchelf-0.8.ebuild,v 1.6 2015/07/29 08:04:07 jlec Exp $
EAPI=5
@@ -19,6 +19,8 @@ IUSE=""
AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${P}-dash.patch )
+
src_prepare() {
rm src/elf.h || die
sed -e 's:-Werror::g' -i configure.ac || die