summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-07 13:52:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-07 13:52:41 +0000
commit7f5c55b46b78b9cbbda60e73c50e585975129410 (patch)
treebd4e9848bed9cf3ea8b048944b2440f795ef5ddb /dev-util
parentCleanup (diff)
downloadgentoo-2-7f5c55b46b78b9cbbda60e73c50e585975129410.tar.gz
gentoo-2-7f5c55b46b78b9cbbda60e73c50e585975129410.tar.bz2
gentoo-2-7f5c55b46b78b9cbbda60e73c50e585975129410.zip
Introduce eric-4.2.5-r1 ( see bug #257976 )
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.2.5-r1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index edff144f48d0..70c5add5ac8f 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.69 2009/01/31 23:07:16 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.70 2009/02/07 13:52:41 hwoarang Exp $
+
+*eric-4.2.5-r1 (07 Feb 2009)
+
+ 07 Feb 2009; Markos Chandras <hwoarang@gentoo.org> +eric-4.2.5-r1.ebuild:
+ Porting to EAPI2, svg use depencency for PyQt4 ( see bug #257976 ), use
+ qt4 use dependency for qscintilla-python
31 Jan 2009; <jokey@gentoo.org> -files/4.1.1-paths.patch,
-eric-4.1.1.ebuild, -eric-4.1.4.ebuild, -eric-4.1.6.ebuild,
diff --git a/dev-util/eric/eric-4.2.5-r1.ebuild b/dev-util/eric/eric-4.2.5-r1.ebuild
new file mode 100644
index 000000000000..650cf0981734
--- /dev/null
+++ b/dev-util/eric/eric-4.2.5-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.2.5-r1.ebuild,v 1.1 2009/02/07 13:52:41 hwoarang Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4[svg]
+ >=dev-python/qscintilla-python-2.2[qt4]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/4.1.4-paths.patch
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}