summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-07-05 12:44:26 +0000
committerMichael Weber <xmw@gentoo.org>2012-07-05 12:44:26 +0000
commit92bb9a757da65bd3b06d5cf787cfdab9299ebb2a (patch)
treed4f3fe6a47e3b92fc75564d2499e673a6333f756 /dev-util
parentStable for amd64, wrt bug #418415 (diff)
downloadgentoo-2-92bb9a757da65bd3b06d5cf787cfdab9299ebb2a.tar.gz
gentoo-2-92bb9a757da65bd3b06d5cf787cfdab9299ebb2a.tar.bz2
gentoo-2-92bb9a757da65bd3b06d5cf787cfdab9299ebb2a.zip
Version bump (thanks David J Cozatt, bug 424814)
(Portage version: 2.1.11.4/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/ChangeLog7
-rw-r--r--dev-util/cppcheck/cppcheck-1.55.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index a13592135751..2ebd1b6c4955 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.31 2012/04/20 10:02:48 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.32 2012/07/05 12:44:26 xmw Exp $
+
+*cppcheck-1.55 (05 Jul 2012)
+
+ 05 Jul 2012; Michael Weber <xmw@gentoo.org> +cppcheck-1.55.ebuild:
+ Version bump (thanks David J Cozatt, bug 424814)
*cppcheck-1.54 (20 Apr 2012)
diff --git a/dev-util/cppcheck/cppcheck-1.55.ebuild b/dev-util/cppcheck/cppcheck-1.55.ebuild
new file mode 100644
index 000000000000..892cc0ba3c5a
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.55.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.55.ebuild,v 1.1 2012/07/05 12:44:26 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-assistant:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}