summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
commit9d54ef8c61839b12b04e3f719f44822578952d2b (patch)
tree42e96e1d4a6c36d7019ce455f02128719347fc90 /dev-util
parentfix license/repoman (diff)
downloadgentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.gz
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.bz2
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.zip
fix license/repoman
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cvsd/cvsd-0.9.19.ebuild39
-rw-r--r--dev-util/gpsim/gpsim-0.20.14.ebuild14
-rw-r--r--dev-util/kprof/kprof-1.4.2.ebuild13
-rw-r--r--dev-util/shc/shc-3.4.ebuild22
-rw-r--r--dev-util/shc/shc-3.6.ebuild17
5 files changed, 45 insertions, 60 deletions
diff --git a/dev-util/cvsd/cvsd-0.9.19.ebuild b/dev-util/cvsd/cvsd-0.9.19.ebuild
index b8d7ac0a1cad..c4f92da60b42 100644
--- a/dev-util/cvsd/cvsd-0.9.19.ebuild
+++ b/dev-util/cvsd/cvsd-0.9.19.ebuild
@@ -1,30 +1,28 @@
-S=${WORKDIR}/${P}
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/cvsd-0.9.19.ebuild,v 1.2 2003/08/07 03:30:25 vapier Exp $
+
DESCRIPTION="CVS pserver daemon"
-SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
-DEPEND="virtual/glibc"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
-src_compile() {
- cd ${S}
- local myconf
-
- use tcpd && myconf="${myconf} --with-libwrap"
-
- econf --prefix=/usr ${myconf} || die
+DEPEND="virtual/glibc"
+src_compile() {
+ local myconf=""
+ use tcpd && myconf="--with-libwrap"
+ econf ${myconf} || die
make || die
}
src_install() {
- exeinto /usr/sbin
- doexe cvsd cvsd-buildroot cvsd-passwd
+ dosbin cvsd cvsd-buildroot cvsd-passwd
insinto /etc/cvsd
- mv cvsd.conf-dist cvsd.conf
- doins cvsd.conf
+ newins cvsd.conf-dist cvsd.conf
dodoc COPYING* ChangeLog* FAQ
dodoc NEWS README* TODO
@@ -32,12 +30,11 @@ src_install() {
doman cvsd-buildroot.8 cvsd-passwd.8 cvsd.8 cvsd.conf.5
exeinto /etc/init.d ; newexe ${FILESDIR}/cvsd.init cvsd
- insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
-
+ insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
}
+
pkg_postinst() {
- einfo
- einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
- einfo
+ einfo
+ einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
+ einfo
}
-
diff --git a/dev-util/gpsim/gpsim-0.20.14.ebuild b/dev-util/gpsim/gpsim-0.20.14.ebuild
index 06e663652c15..2c6d35bcf196 100644
--- a/dev-util/gpsim/gpsim-0.20.14.ebuild
+++ b/dev-util/gpsim/gpsim-0.20.14.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Copyright 2003 Alex Holden <alex@alexholden.net>
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gpsim/gpsim-0.20.14.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gpsim/gpsim-0.20.14.ebuild,v 1.3 2003/08/07 03:32:14 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
-SRC_URI="http://www.dattalo.com/gnupic/${P}.tar.gz"
HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html"
+SRC_URI="http://www.dattalo.com/gnupic/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
DEPEND="x11-libs/gtk+extra"
@@ -17,7 +17,7 @@ DEPEND="x11-libs/gtk+extra"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gcc3.2.patch
+ epatch ${FILESDIR}/${P}-gcc3.2.patch
}
src_compile(){
diff --git a/dev-util/kprof/kprof-1.4.2.ebuild b/dev-util/kprof/kprof-1.4.2.ebuild
index 99b02e6ba506..d32bc21e1263 100644
--- a/dev-util/kprof/kprof-1.4.2.ebuild
+++ b/dev-util/kprof/kprof-1.4.2.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.2.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.2.ebuild,v 1.3 2003/08/07 03:31:38 vapier Exp $
inherit kde-base
need-kde 3
-IUSE=""
DESCRIPTION="A KDE3 visual tool helping developers to analyze the profiling results generated by code profilers."
+HOMEPAGE="http://kprof.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://kprof.sourceforge.net"
-LICENSE="GPL-2"
+
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
src_unpack() {
base_src_unpack
-
# Rename the source directory to include the version to make the eclass happy
mv ${WORKDIR}/${PN} ${WORKDIR}/${P}
}
-
diff --git a/dev-util/shc/shc-3.4.ebuild b/dev-util/shc/shc-3.4.ebuild
index b483ad07f3e4..2d25d9f81351 100644
--- a/dev-util/shc/shc-3.4.ebuild
+++ b/dev-util/shc/shc-3.4.ebuild
@@ -1,33 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.4.ebuild,v 1.3 2003/02/13 12:00:30 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.4.ebuild,v 1.4 2003/08/07 03:31:15 vapier Exp $
-IUSE=""
-
-DESCRIPTION="A (shell-) script compiler/scrambler."
-SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+DESCRIPTION="A (shell-) script compiler/scrambler"
HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc"
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
-}
-
src_compile() {
## the "test"-target leads to an access-violation -> so we skip it
## as it's only for demonstration purposes anyway.
make shc || die
}
-src_install () {
- exeinto /usr/bin
- doexe shc
+src_install() {
+ dobin shc
doman shc.1
dodoc shc.README CHANGES
}
diff --git a/dev-util/shc/shc-3.6.ebuild b/dev-util/shc/shc-3.6.ebuild
index 1884e1040a3a..4041e4175345 100644
--- a/dev-util/shc/shc-3.6.ebuild
+++ b/dev-util/shc/shc-3.6.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.6.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.6.ebuild,v 1.3 2003/08/07 03:31:15 vapier Exp $
-IUSE=""
-
-DESCRIPTION="A (shell-) script compiler/scrambler."
-SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+DESCRIPTION="A (shell-) script compiler/scrambler"
HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc"
@@ -20,9 +18,8 @@ src_compile() {
make shc || die
}
-src_install () {
- exeinto /usr/bin
- doexe shc
+src_install() {
+ dobin shc
doman shc.1
dodoc shc.README CHANGES
}