summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-05-27 06:07:23 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-05-27 06:07:23 +0000
commita622b4c7c0c12047900161158e54aaf350ca5b92 (patch)
treeb47c9a42a0cc4d9dff625fb89679b188442d69a9 /dev-util
parentCleanup. (diff)
downloadgentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.tar.gz
gentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.tar.bz2
gentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.zip
Version bump (bug #469172) including EAPI-5 bump/usage and dependency fixes. Drop old.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cflow/ChangeLog13
-rw-r--r--dev-util/cflow/cflow-1.4.ebuild (renamed from dev-util/cflow/cflow-1.3.ebuild)29
-rw-r--r--dev-util/cflow/files/cflow-1.2-info-direntry.patch11
-rw-r--r--dev-util/cflow/files/cflow-1.4-info-direntry.patch13
4 files changed, 37 insertions, 29 deletions
diff --git a/dev-util/cflow/ChangeLog b/dev-util/cflow/ChangeLog
index 943ee00ccef7..27940a5aa106 100644
--- a/dev-util/cflow/ChangeLog
+++ b/dev-util/cflow/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cflow
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cflow/ChangeLog,v 1.10 2009/09/12 01:13:22 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cflow/ChangeLog,v 1.11 2013/05/27 06:07:23 dev-zero Exp $
+
+*cflow-1.4 (27 May 2013)
+
+ 27 May 2013; Tiziano Müller <dev-zero@gentoo.org> +cflow-1.4.ebuild,
+ +files/cflow-1.4-info-direntry.patch, -cflow-1.3.ebuild,
+ -files/cflow-1.2-info-direntry.patch:
+ Version bump (bug #469172) including EAPI-5 bump/usage and dependency fixes.
+ Drop old.
*cflow-1.3 (12 Sep 2009)
@@ -47,4 +55,3 @@
+cflow-1.0.ebuild:
Initial import to the tree. This closes bug #127078. Thanks to Tomoyuki
Sakurai for the ebuid.
-
diff --git a/dev-util/cflow/cflow-1.3.ebuild b/dev-util/cflow/cflow-1.4.ebuild
index d0774cf101b5..c872bc80d005 100644
--- a/dev-util/cflow/cflow-1.3.ebuild
+++ b/dev-util/cflow/cflow-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cflow/cflow-1.3.ebuild,v 1.2 2009/10/12 16:47:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cflow/cflow-1.4.ebuild,v 1.1 2013/05/27 06:07:23 dev-zero Exp $
-EAPI="2"
+EAPI="5"
inherit elisp-common eutils
@@ -15,40 +15,39 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug emacs nls"
-DEPEND="nls? ( sys-devel/gettext )
- emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}"
+RDEPEND="emacs? ( virtual/emacs )
+ nls? ( virtual/libintl virtual/libiconv )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
- epatch "${FILESDIR}/${PN}-1.2-info-direntry.patch"
+ epatch "${FILESDIR}/${P}-info-direntry.patch"
}
src_configure() {
econf \
$(use_enable nls) \
$(use_enable debug) \
- EMACS=no \
- || die "econf failed"
+ EMACS=no
}
src_compile() {
- emake || die "emake failed"
+ default
if use emacs; then
- elisp-compile elisp/cflow-mode.el || die
+ elisp-compile elisp/cflow-mode.el
fi
}
src_install() {
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ default
doinfo doc/cflow.info
- emake DESTDIR="${D}" install || die "emake install failed"
if use emacs; then
- elisp-install ${PN} elisp/cflow-mode.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ elisp-install ${PN} elisp/cflow-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}
diff --git a/dev-util/cflow/files/cflow-1.2-info-direntry.patch b/dev-util/cflow/files/cflow-1.2-info-direntry.patch
deleted file mode 100644
index 57fb00a091f9..000000000000
--- a/dev-util/cflow/files/cflow-1.2-info-direntry.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cflow-1.2-orig/doc/cflow.texi 2007-06-27 16:16:46.000000000 +0200
-+++ cflow-1.2/doc/cflow.texi 2008-11-28 15:51:36.000000000 +0100
-@@ -22,7 +22,7 @@
- @end direntry
- @dircategory Emacs
- @direntry
--* cflow mode: (cflow)cflow mode. Major mode for visiting cflow charts.
-+* cflow mode: (cflow)Emacs. Major mode for visiting cflow charts.
- @end direntry
- @end ifinfo
-
diff --git a/dev-util/cflow/files/cflow-1.4-info-direntry.patch b/dev-util/cflow/files/cflow-1.4-info-direntry.patch
new file mode 100644
index 000000000000..ab7e4956425f
--- /dev/null
+++ b/dev-util/cflow/files/cflow-1.4-info-direntry.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/cflow.texi b/doc/cflow.texi
+index dfb1fdf..5dc1d48 100644
+--- a/doc/cflow.texi
++++ b/doc/cflow.texi
+@@ -21,7 +21,7 @@
+ @end direntry
+ @dircategory Emacs
+ @direntry
+-* cflow mode: (cflow)cflow mode. Major mode for visiting cflow charts.
++* cflow mode: (cflow)Emacs. Major mode for visiting cflow charts.
+ @end direntry
+ @end ifinfo
+