summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-06 19:45:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-06 19:45:07 +0000
commitabf4fcb67436d8cec5d44fe1199eb76376737547 (patch)
tree5a35e5b71823248c70ed74b3d9972bcb75b14980 /dev-util
parentWarn instead of error when both java5 and java6 are set. The java6 flag takes... (diff)
downloadgentoo-2-abf4fcb67436d8cec5d44fe1199eb76376737547.tar.gz
gentoo-2-abf4fcb67436d8cec5d44fe1199eb76376737547.tar.bz2
gentoo-2-abf4fcb67436d8cec5d44fe1199eb76376737547.zip
Version bump.
(Portage version: 14504-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/global/ChangeLog8
-rw-r--r--dev-util/global/global-5.6.2.ebuild68
-rw-r--r--dev-util/global/global-5.7.6.ebuild (renamed from dev-util/global/global-5.7.4.ebuild)12
3 files changed, 13 insertions, 75 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 0eb2de48943f..8f867411f079 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/global
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.38 2009/05/06 10:12:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.39 2009/10/06 19:45:07 arfrever Exp $
+
+*global-5.7.6 (06 Oct 2009)
+
+ 06 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -global-5.6.2.ebuild, -global-5.7.4.ebuild, +global-5.7.6.ebuild:
+ Version bump.
06 May 2009; Christian Faulhammer <fauli@gentoo.org> global-5.7.5.ebuild:
stable x86, bug 267439
diff --git a/dev-util/global/global-5.6.2.ebuild b/dev-util/global/global-5.6.2.ebuild
deleted file mode 100644
index f67fc0c960f0..000000000000
--- a/dev-util/global/global-5.6.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.6.2.ebuild,v 1.6 2008/08/24 01:38:53 ulm Exp $
-
-inherit elisp-common
-
-DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
-HOMEPAGE="http://www.gnu.org/software/global/global.html"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc x86"
-IUSE="doc vim emacs"
-
-RDEPEND="vim? ( || ( app-editors/vim app-editors/gvim ) )
- emacs? ( virtual/emacs )"
-DEPEND="${DEPEND}
- doc? ( sys-apps/texinfo )"
-
-SITEFILE=50gtags-gentoo.el
-
-src_compile() {
- econf || die "econf failed"
-
- if use doc; then
- texi2pdf -q -o doc/global.pdf doc/global.txi
- texi2html -o doc/global.html doc/global.txi
- fi
-
- if use emacs; then
- elisp-compile *.el || die "elisp-compile failed"
- fi
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use doc; then
- dohtml doc/global.html
- dodoc doc/global.pdf
- fi
- dodoc AUTHORS FAQ NEWS README THANKS
-
- insinto /etc
- doins gtags.conf
- insinto /usr/share/${PN}
- doins gtags.pl globash.rc
-
- if use vim; then
- insinto /usr/share/vim/vimfiles/plugin
- doins gtags.vim
- fi
-
- if use emacs; then
- elisp-install gtags *.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/global/global-5.7.4.ebuild b/dev-util/global/global-5.7.6.ebuild
index 32fc3fcb8a8b..f4e7ac51b874 100644
--- a/dev-util/global/global-5.7.4.ebuild
+++ b/dev-util/global/global-5.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.7.4.ebuild,v 1.1 2009/01/13 19:12:41 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.7.6.ebuild,v 1.1 2009/10/06 19:45:07 arfrever Exp $
inherit elisp-common
@@ -16,16 +16,16 @@ IUSE="doc vim emacs"
RDEPEND="vim? ( || ( app-editors/vim app-editors/gvim ) )
emacs? ( virtual/emacs )"
DEPEND="${DEPEND}
- doc? ( sys-apps/texinfo )"
+ doc? ( app-text/texi2html sys-apps/texinfo )"
SITEFILE=50gtags-gentoo.el
src_compile() {
- econf || die "econf failed"
+ econf
if use doc; then
- texi2pdf -q -o doc/global.pdf doc/global.txi
- texi2html -o doc/global.html doc/global.txi
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
fi
if use emacs; then
@@ -39,7 +39,7 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
if use doc; then
dohtml doc/global.html
- dodoc doc/global.pdf
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
fi
dodoc AUTHORS FAQ NEWS README THANKS