summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-07-23 09:17:19 +0000
committerMichael Januszewski <spock@gentoo.org>2007-07-23 09:17:19 +0000
commitafe39b1496662bc64bfe56f1e68efa390cb9945a (patch)
tree3530ee82cca6763e2b9b8db327e61db6a97c0c67 /dev-util
parentStable on x86, security bug #185886. (diff)
downloadgentoo-2-afe39b1496662bc64bfe56f1e68efa390cb9945a.tar.gz
gentoo-2-afe39b1496662bc64bfe56f1e68efa390cb9945a.tar.bz2
gentoo-2-afe39b1496662bc64bfe56f1e68efa390cb9945a.zip
Version bump.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog7
-rw-r--r--dev-util/oprofile/files/digest-oprofile-0.9.33
-rw-r--r--dev-util/oprofile/oprofile-0.9.3.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index c5277127e8d1..eaaaaf5db282 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.40 2007/04/16 15:15:00 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.41 2007/07/23 09:17:19 spock Exp $
+
+*oprofile-0.9.3 (23 Jul 2007)
+
+ 23 Jul 2007; Michał Januszewski <spock@gentoo.org> +oprofile-0.9.3.ebuild:
+ Version bump.
16 Apr 2007; Michał Januszewski <spock@gentoo.org>
oprofile-0.9.1-r1.ebuild, oprofile-0.9.2.ebuild:
diff --git a/dev-util/oprofile/files/digest-oprofile-0.9.3 b/dev-util/oprofile/files/digest-oprofile-0.9.3
new file mode 100644
index 000000000000..f1866f3507ae
--- /dev/null
+++ b/dev-util/oprofile/files/digest-oprofile-0.9.3
@@ -0,0 +1,3 @@
+MD5 bb91e4d5bd45ff0d5c3e6214653422b7 oprofile-0.9.3.tar.gz 853593
+RMD160 adcacb204b9061aebf761d6545e4f0b1ba1c4608 oprofile-0.9.3.tar.gz 853593
+SHA256 4f86ab165dabcc7bc4008710a66fa0ed391c083e2a8bdf8a8f5bf11c0244b2cb oprofile-0.9.3.tar.gz 853593
diff --git a/dev-util/oprofile/oprofile-0.9.3.ebuild b/dev-util/oprofile/oprofile-0.9.3.ebuild
new file mode 100644
index 000000000000..b9574017b55b
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.3.ebuild,v 1.1 2007/07/23 09:17:19 spock Exp $
+
+inherit eutils qt3 linux-info
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt3"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt3? ( $(qt_min_version 3.3) )"
+
+src_compile() {
+ local myconf=""
+
+ if use qt3
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case ${KV_FULL} in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '${KV_FULL}' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == / ]] ; then
+ [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
+ fi
+
+ echo
+ elog "Now load the oprofile module by running:"
+ elog " # opcontrol --init"
+ elog "Then read manpages and this html doc:"
+ elog " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}