summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 18:30:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 18:30:49 +0000
commitb004b4baf6fa32b2f61ca1fe55500c3e22d68c75 (patch)
tree4251aa64b055c8289af4604860209c6bb879b218 /dev-util
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-b004b4baf6fa32b2f61ca1fe55500c3e22d68c75.tar.gz
gentoo-2-b004b4baf6fa32b2f61ca1fe55500c3e22d68c75.tar.bz2
gentoo-2-b004b4baf6fa32b2f61ca1fe55500c3e22d68c75.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/glade/ChangeLog7
-rw-r--r--dev-util/glade/glade-3.18.2.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index a1fa31d147c3..3d707ec1ed1b 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/glade
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.212 2014/04/26 07:24:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.213 2014/04/27 18:30:49 eva Exp $
+
+*glade-3.18.2 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +glade-3.18.2.ebuild:
+ Version bump for Gnome 3.12.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -glade-3.12.2.ebuild,
-glade-3.14.2.ebuild, -glade-3.8.3.ebuild:
diff --git a/dev-util/glade/glade-3.18.2.ebuild b/dev-util/glade/glade-3.18.2.ebuild
new file mode 100644
index 000000000000..c5d615c302bc
--- /dev/null
+++ b/dev-util/glade/glade-3.18.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.18.2.ebuild,v 1.1 2014/04/27 18:30:49 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1 versionator virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="http://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+introspection python"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ epatch \
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch \
+ "${FILESDIR}"/${PN}-3.16.1-underlinking.patch
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}