summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-07 12:30:31 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-07 12:30:31 +0000
commitde5fdab9808616d7aae7a74c32f7cc3bba2dd8d1 (patch)
tree449cea594c006e59ba2865ee0c0319408e7783e0 /dev-util
parentDelete "crypt" USE flag (bug #307345). (diff)
downloadgentoo-2-de5fdab9808616d7aae7a74c32f7cc3bba2dd8d1.tar.gz
gentoo-2-de5fdab9808616d7aae7a74c32f7cc3bba2dd8d1.tar.bz2
gentoo-2-de5fdab9808616d7aae7a74c32f7cc3bba2dd8d1.zip
Disable rss news on request (bug #302978). Drop old ebuild
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/qt-creator/ChangeLog6
-rw-r--r--dev-util/qt-creator/qt-creator-1.3.0.ebuild92
-rw-r--r--dev-util/qt-creator/qt-creator-1.3.1.ebuild12
3 files changed, 15 insertions, 95 deletions
diff --git a/dev-util/qt-creator/ChangeLog b/dev-util/qt-creator/ChangeLog
index 982dd29d7854..b44693f161aa 100644
--- a/dev-util/qt-creator/ChangeLog
+++ b/dev-util/qt-creator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/qt-creator
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/ChangeLog,v 1.44 2010/03/03 09:18:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/ChangeLog,v 1.45 2010/03/07 12:30:31 hwoarang Exp $
+
+ 07 Mar 2010; Markos Chandras <hwoarang@gentoo.org>
+ -qt-creator-1.3.0.ebuild, qt-creator-1.3.1.ebuild:
+ Disable rss news on request (bug #302978). Drop old ebuild
03 Mar 2010; Markos Chandras <hwoarang@gentoo.org>
qt-creator-1.3.0.ebuild:
diff --git a/dev-util/qt-creator/qt-creator-1.3.0.ebuild b/dev-util/qt-creator/qt-creator-1.3.0.ebuild
deleted file mode 100644
index fa19c458bd77..000000000000
--- a/dev-util/qt-creator/qt-creator-1.3.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.3.0.ebuild,v 1.7 2010/03/06 12:53:27 djc Exp $
-
-EAPI="2"
-LANGS="de es fr it ja pl ru sl"
-
-inherit qt4-r2 multilib
-MY_PN="${PN/-/}"
-
-DESCRIPTION="Lightweight IDE for C++ development centering around Qt"
-HOMEPAGE="http://labs.qtsoftware.com/page/Projects/Tools/QtCreator"
-SRC_URI="http://get.qt.nokia.com/${MY_PN}/${P}-src.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bineditor bookmarks +cmake cvs debug +designer doc examples fakevim git kde mercurial perforce qtscript subversion"
-
-DEPEND=">=x11-libs/qt-assistant-4.6.0:4
- >=x11-libs/qt-gui-4.6.0:4[dbus,qt3support]"
-
-RDEPEND="${DEPEND}
- >=x11-libs/qt-sql-4.6.0:4
- >=x11-libs/qt-svg-4.6.0:4
- >=x11-libs/qt-test-4.6.0:4
- >=x11-libs/qt-webkit-4.6.0:4
- !kde? ( || ( >=x11-libs/qt-phonon-4.6.0:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- cmake? ( dev-util/cmake )
- cvs? ( dev-util/cvs )
- sys-devel/gdb
- examples? ( >=x11-libs/qt-demo-4.6.0:4 )
- git? ( dev-util/git )
- mercurial? ( dev-vcs/mercurial )
- qtscript? ( >=x11-libs/qt-script-4.6.0:4 )
- subversion? ( dev-util/subversion )"
-
-PLUGINS="bookmarks bineditor cmake cvs designer fakevim git mercurial perforce qtscript subversion"
-
-src_prepare() {
- qt4_src_prepare
-
- # bug 263087
- for plugin in ${PLUGINS};do
- if ! use ${plugin};then
- einfo "Disabling ${plugin} support"
- if [[ ${plugin} == "cmake" ]];then
- plugin="cmakeprojectmanager"
- elif [[ ${plugin} == "qtscript" ]];then
- plugin="qtscripteditor"
- fi
- sed -i "/plugin_${plugin}/s:^:#:" src/plugins/plugins.pro \
- || die "Failed to disable ${plugin} plugin"
- fi
- done
-
- if use perforce;then
- ewarn
- ewarn "You have enabled perforce plugin."
- ewarn "In order to use it, you need to manually"
- ewarn "download perforce client from http://www.perforce.com/perforce/downloads/index.html"
- ewarn
- ebeep 5
- fi
-}
-
-src_configure() {
- eqmake4 ${MY_PN}.pro IDE_LIBRARY_BASENAME="$(get_libdir)"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}/usr" install_subtargets || die "emake install failed"
- # fix binary name bug 275859
- mv "${D}"/usr/bin/${MY_PN}.bin "${D}"/usr/bin/${MY_PN} || die "failed to rename executable"
- if use doc;then
- emake INSTALL_ROOT="${D}/usr" install_qch_docs || die "emake install qch_docs failed"
- fi
- make_desktop_entry ${MY_PN} QtCreator qtcreator_logo_48 \
- 'Qt;Development;IDE' || die "make_desktop_entry failed"
-
- # install translations
- insinto /usr/share/${MY_PN}/translations/
- for x in ${LINGUAS};do
- for lang in ${LANGS};do
- if [[ ${x} == ${lang} ]];then
- doins share/${MY_PN}/translations/${MY_PN}_${x}.qm \
- || die "failed to install translations"
- fi
- done
- done
-}
diff --git a/dev-util/qt-creator/qt-creator-1.3.1.ebuild b/dev-util/qt-creator/qt-creator-1.3.1.ebuild
index d81f7eb26a77..474dbd0ee9b3 100644
--- a/dev-util/qt-creator/qt-creator-1.3.1.ebuild
+++ b/dev-util/qt-creator/qt-creator-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.3.1.ebuild,v 1.7 2010/03/06 12:53:27 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qt-creator/qt-creator-1.3.1.ebuild,v 1.8 2010/03/07 12:30:31 hwoarang Exp $
EAPI="2"
LANGS="de es fr it ja pl ru sl"
@@ -15,7 +15,8 @@ SRC_URI="http://get.qt.nokia.com/${MY_PN}/${P}-src.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="bineditor bookmarks +cmake cvs debug +designer doc examples fakevim git kde mercurial perforce qml qtscript subversion"
+IUSE="bineditor bookmarks +cmake cvs debug +designer doc examples fakevim git
+kde mercurial perforce qml qtscript rss subversion"
DEPEND=">=x11-libs/qt-assistant-4.6.0:4
>=x11-libs/qt-gui-4.6.0:4[dbus,qt3support]"
@@ -72,6 +73,13 @@ src_prepare() {
ewarn
ebeep 5
fi
+ # disable rss news on startup ( bug #302978 )
+ if ! use rss; then
+ einfo "Disabling RSS welcome news"
+ sed -i "/m_rssFetcher->fetch/s:^:\/\/:" \
+ src/plugins/welcome/communitywelcomepagewidget.cpp \
+ || die "failed to disable rss"
+ fi
}
src_configure() {