summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-28 17:39:49 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-28 17:39:49 +0000
commitf27159ed711103a633f2445f4a2226fa960c830a (patch)
tree5929b70b1916993256458e488e31e3079af12372 /dev-util
parentMarking ~hppa (Manifest recommit) (diff)
downloadgentoo-2-f27159ed711103a633f2445f4a2226fa960c830a.tar.gz
gentoo-2-f27159ed711103a633f2445f4a2226fa960c830a.tar.bz2
gentoo-2-f27159ed711103a633f2445f4a2226fa960c830a.zip
Intermediate fixups of the DEPEND and RDEPEND.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog8
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild34
-rw-r--r--dev-util/eclipse-sdk/files/eclipse-350
-rw-r--r--dev-util/eclipse-sdk/files/eclipse-3.desktop9
4 files changed, 85 insertions, 16 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 8ae2d6985baa..fa65d8341f5f 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.10 2004/03/24 17:20:07 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.11 2004/03/28 17:39:48 karltk Exp $
+ 28 Mar 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-2.1.3.ebuild:
+ Cleaned the RDEPEND and DEPEND a bit, trying to move away from the ?:
+ notation, but the new || () notation is not working properly, so we can't
+ yet.
+
25 Mar 2004; Lim Swee Tat <st_lim@gentoo.org>
eclipse-sdk-2.1.2-r1.ebuild:
Updated eclipse-sdk-2.1.2-r1 and added eclipse-2.1.3 There is a deprecation of
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild
index 062bc9f4fa4e..bb4e428037b9 100644
--- a/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild
+++ b/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild,v 1.1 2004/03/24 17:20:07 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-2.1.3.ebuild,v 1.2 2004/03/28 17:39:48 karltk Exp $
DESCRIPTION="Eclipse Tools Platform"
HOMEPAGE="http://www.eclipse.org/"
@@ -11,25 +11,29 @@ SLOT="0"
LICENSE="CPL-1.0"
KEYWORDS="~x86 ~ppc ~sparc"
+RDEPEND=">=virtual/jdk-1.3
+ gtk? ( >=x11-libs/gtk+-2.4 ) :
+ ( kde? ( kde-base/kde x11-libs/openmotif ) :
+ ( motif? ( x11-libs/openmotif ) :
+ ( >=x11-libs/gtk+-2.4 )
+ )
+ )
+ gnome? ( =gnome-base/gnome-vfs-2* )
+ "
+# 2004-03-28: karltk
+# It would be nice if this worked, but portage doesn't handle it properly
+# || (
+# gtk? ( >=x11-libs/gtk+-2.4 )
+# kde? ( kde-base/kde x11-libs/openmotif )
+# motif? ( x11-libs/openmotif )
+# >=x11-libs/gtk+-2.4
+# )
+
DEPEND="${RDEPEND}
>=dev-java/ant-1.5.3
>=sys-apps/findutils-4.1.7
>=app-shells/tcsh-6.11"
-# removed since the bin lives in /opt and this in /usr
-# !dev-util/eclipse-platform-bin
-# !dev-util/eclipse-jdt-bin
-# !dev-util/eclipse-cdt-bin"
-
-RDEPEND=">=virtual/jdk-1.3
- kde? ( kde-base/kde x11-libs/openmotif ) :
- ( gnome? ( =gnome-base/gnome-vfs-2* ) :
- ( motif? ( x11-libs/openmotif ) :
- ( >=x11-libs/gtk+-2.2.1-r1 ) ) )
- motif? ( x11-libs/openmotif )
- gnome? ( =gnome-base/gnome-vfs-2* )
- gtk? ( >=x11-libs/gtk+-2.4 )"
-
S=${WORKDIR}/eclipse
src_compile() {
diff --git a/dev-util/eclipse-sdk/files/eclipse-3 b/dev-util/eclipse-sdk/files/eclipse-3
new file mode 100644
index 000000000000..0a1d2165f58d
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/eclipse-3
@@ -0,0 +1,50 @@
+#!/bin/bash
+#
+# tiny eclipse wrapper script to allow per user workbenches
+# under each user's home.
+#
+# (c) March 2003 D. Seyffer <uid0@getroot.de>
+#
+
+ECLIPSE_DIR="/usr/lib/eclipse"
+if [ "`basename $0`" = "eclipse-motif" ] ; then
+ ECLIPSE="${ECLIPSE_DIR}/eclipse-motif";
+else
+ ECLIPSE="${ECLIPSE_DIR}/eclipse";
+fi
+WORKBENCH="${HOME}/.eclipse/"
+
+###################################################
+
+if [ ! -d ${ECLIPSE_DIR} ] ; then
+ echo " Eclipse directory not found.";
+ exit 1;
+else
+ echo " Eclipse found.";
+fi
+
+
+if [ ! -x ${ECLIPSE} ] ; then
+ echo " Eclipse executable not found or not executable.";
+ exit 1;
+else
+ echo " Executable found and is executable.";
+fi
+
+
+if [ ! -d ${WORKBENCH} ] ; then
+ echo " No existing workbench for current user!";
+ echo " First time startup? Will prepare and have eclipse create one...";
+ mkdir -p ${WORKBENCH}
+ if [ ! -d ${WORKBENCH} ] ; then
+ echo " Error creating workbench env!";
+ exit 1;
+ fi
+else
+ echo " Found existing workbench directory for current user.";
+fi
+
+echo " Starting Eclipse...";
+cd ${WORKBENCH}
+${ECLIPSE}
+
diff --git a/dev-util/eclipse-sdk/files/eclipse-3.desktop b/dev-util/eclipse-sdk/files/eclipse-3.desktop
new file mode 100644
index 000000000000..e895973f3b9d
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/eclipse-3.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Eclipse 3
+Comment=A Java Development Environment
+Icon=/usr/lib/eclipse/icon.xpm
+Exec=/usr/bin/eclipse-3
+Terminal=false
+Type=Application
+Categories=GNOME;Application;Development
+StartupNotify=true