summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-07 01:10:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-07 01:10:30 +0000
commitf4aa376de0d569057075149a22d100e7527b1974 (patch)
tree644290e0f9cb2f1239a25936812edbd6923f5fdb /dev-util
parenttrim whitespace (diff)
downloadgentoo-2-f4aa376de0d569057075149a22d100e7527b1974.tar.gz
gentoo-2-f4aa376de0d569057075149a22d100e7527b1974.tar.bz2
gentoo-2-f4aa376de0d569057075149a22d100e7527b1974.zip
Add a patch to follow fake arm syscalls.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog8
-rw-r--r--dev-util/strace/files/strace-fix-arm-bad-syscall.patch20
-rw-r--r--dev-util/strace/strace-4.5.12.ebuild3
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index d4fd638f5300..e55024402886 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/strace
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.69 2005/11/20 07:34:16 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.70 2006/01/07 01:10:30 vapier Exp $
+
+ 07 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/strace-fix-arm-bad-syscall.patch, strace-4.5.12.ebuild:
+ Add a patch to follow fake arm syscalls.
20 Nov 2005; Mike Frysinger <vapier@gentoo.org>
files/strace-4.5.12-libaio.patch, strace-4.5.12.ebuild:
diff --git a/dev-util/strace/files/strace-fix-arm-bad-syscall.patch b/dev-util/strace/files/strace-fix-arm-bad-syscall.patch
new file mode 100644
index 000000000000..125440dd81e4
--- /dev/null
+++ b/dev-util/strace/files/strace-fix-arm-bad-syscall.patch
@@ -0,0 +1,20 @@
+http://www.fluff.org/ben/patches/strace/
+
+--- strace-4.5.12-orig/syscall.c 2005-06-08 21:45:28.000000000 +0100
++++ strace-4.5.12/syscall.c 2005-10-25 19:26:39.000000000 +0100
+@@ -1013,6 +1013,15 @@ struct tcb *tcp;
+ /*
+ * Note: we only deal with only 32-bit CPUs here.
+ */
++
++ if (!(tcp->flags & TCB_INSYSCALL) &&
++ (tcp->flags & TCB_WAITEXECVE)) {
++ /* caught a fake syscall from the execve's exit */
++ tcp->flags &= ~TCB_WAITEXECVE;
++ return 0;
++ }
++
++
+ if (regs.ARM_cpsr & 0x20) {
+ /*
+ * Get the Thumb-mode system call number
diff --git a/dev-util/strace/strace-4.5.12.ebuild b/dev-util/strace/strace-4.5.12.ebuild
index 7c3c1edaebae..4578814f8ad9 100644
--- a/dev-util/strace/strace-4.5.12.ebuild
+++ b/dev-util/strace/strace-4.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.12.ebuild,v 1.6 2006/01/06 01:05:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.12.ebuild,v 1.7 2006/01/07 01:10:30 vapier Exp $
inherit flag-o-matic
@@ -29,6 +29,7 @@ src_unpack() {
# Fix building on older ARM machines
epatch "${FILESDIR}"/strace-undef-syscall.patch
+ epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
# Fix libaio support #103427
epatch "${FILESDIR}"/${P}-libaio.patch