summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-27 08:35:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-27 08:35:09 +0000
commitf561b57282ea9f811c130d8f04e3b6f281244af0 (patch)
tree7a8a67cb0a0b8de52ec880df688b7f994154dbe3 /dev-util
parentupdate wrapper to match new gcc-config behavior where all env.d files contain... (diff)
downloadgentoo-2-f561b57282ea9f811c130d8f04e3b6f281244af0.tar.gz
gentoo-2-f561b57282ea9f811c130d8f04e3b6f281244af0.tar.bz2
gentoo-2-f561b57282ea9f811c130d8f04e3b6f281244af0.zip
Version bump.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/nsis/ChangeLog7
-rw-r--r--dev-util/nsis/files/digest-nsis-2.293
-rw-r--r--dev-util/nsis/nsis-2.29.ebuild94
3 files changed, 103 insertions, 1 deletions
diff --git a/dev-util/nsis/ChangeLog b/dev-util/nsis/ChangeLog
index f7b3a63be4f4..739d0dd5d5e9 100644
--- a/dev-util/nsis/ChangeLog
+++ b/dev-util/nsis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/nsis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.11 2007/06/19 20:08:20 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.12 2007/07/27 08:35:09 vapier Exp $
+
+*nsis-2.29 (27 Jul 2007)
+
+ 27 Jul 2007; Mike Frysinger <vapier@gentoo.org> +nsis-2.29.ebuild:
+ Version bump.
*nsis-2.28 (19 Jun 2007)
diff --git a/dev-util/nsis/files/digest-nsis-2.29 b/dev-util/nsis/files/digest-nsis-2.29
new file mode 100644
index 000000000000..a14f978532ea
--- /dev/null
+++ b/dev-util/nsis/files/digest-nsis-2.29
@@ -0,0 +1,3 @@
+MD5 b62ac91286891fdd692591480fef97be nsis-2.29-src.tar.bz2 1453149
+RMD160 c17f5cc950790b0504a5c5e799e1eea658a70301 nsis-2.29-src.tar.bz2 1453149
+SHA256 b27c4db9b0ef064f1b9ae191fc209c84645560d5912ef3b9138392321c41d44d nsis-2.29-src.tar.bz2 1453149
diff --git a/dev-util/nsis/nsis-2.29.ebuild b/dev-util/nsis/nsis-2.29.ebuild
new file mode 100644
index 000000000000..b0cb73cb9a7f
--- /dev/null
+++ b/dev-util/nsis/nsis-2.29.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.29.ebuild,v 1.1 2007/07/27 08:35:09 vapier Exp $
+
+mingw32_variants=$(eval echo {,i{6,5,4,3}86-}mingw32)
+
+DESCRIPTION="Nullsoft Scriptable Install System"
+HOMEPAGE="http://nsis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 config-log zlib"
+
+# NSIS Menu uses wxwindows but it's all broken, so disable for now
+# wxwindows? ( x11-libs/wxGTK )
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.96.93"
+
+S=${WORKDIR}/${P}-src
+
+mingw_CTARGET() {
+ local i
+ for i in ${mingw32_variants} ; do
+ type -P ${i}-gcc > /dev/null && echo ${i} && return
+ done
+}
+
+pkg_setup() {
+ [[ -n $(mingw_CTARGET) ]] && return 0
+
+ local i
+ eerror "Before you could emerge nsis, you need to install mingw32."
+ eerror "Run the following command:"
+ eerror " emerge crossdev"
+ eerror "then run _one_ of the following commands:"
+ for i in ${mingw32_variants} ; do
+ eerror " crossdev ${i}"
+ done
+ die "mingw32 is needed"
+}
+
+get_additional_options() {
+ echo \
+ PREFIX=/usr \
+ PREFIX_CONF=/etc \
+ PREFIX_DOC=/usr/share/doc/${PF} \
+ PREFIX_DEST=\"${D}\" \
+ VERSION=${PV} \
+ DEBUG=no \
+ STRIP=no
+ echo \
+ SKIPSTUBS=\"$(use zlib || echo zlib) $(use bzip2 || echo bzip2)\" \
+ SKIPPLUGINS=\"\" \
+ SKIPUTILS=\"NSIS Menu\" \
+ SKIPMISC=\"\"
+ use config-log && echo NSIS_CONFIG_LOG=yes
+}
+do_scons() {
+ local cmd=$1
+ eval set -- $(get_additional_options)
+ echo scons $(get_additional_options) ${cmd}
+ scons "$@" ${cmd}
+}
+
+src_compile() {
+ do_scons || die "scons failed"
+}
+
+src_install() {
+ do_scons install || die "scons failed"
+
+ fperms -R go-w,a-x,a+X /usr/share/${PN}/ /usr/share/doc/${PF}/ /etc/nsisconf.nsh
+
+ src_strip_win32
+}
+
+src_strip_win32() {
+ # need to strip win32 binaries ourselves ... should fold this
+ # back in to prepstrip at some point
+ local STRIP_PROG=$(mingw_CTARGET)-strip
+ local STRIP_FLAGS="--strip-unneeded"
+
+ echo
+ echo "strip: ${STRIP_PROG} ${STRIP_FLAGS}"
+ local FILE
+ for FILE in $(find "${D}" -iregex '.*\.\(dll\|exe\)$') ; do
+ echo " ${FILE#${D}}"
+ ${STRIP_PROG} ${STRIP_FLAGS} "${FILE}"
+ done
+}