summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-20 04:26:40 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-20 04:26:40 +0000
commitfeefef6e4a238896fd19c0e8cddd06db495b1cd6 (patch)
tree0ec2153fe211af432ce88701b5c67978d600da04 /dev-util
parentadd FFLAGS to default info output (diff)
downloadgentoo-2-feefef6e4a238896fd19c0e8cddd06db495b1cd6.tar.gz
gentoo-2-feefef6e4a238896fd19c0e8cddd06db495b1cd6.tar.bz2
gentoo-2-feefef6e4a238896fd19c0e8cddd06db495b1cd6.zip
Version bump. Removed old versions. Fixed 0.97 ebuild and this closes bug #223527
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scons/ChangeLog10
-rw-r--r--dev-util/scons/scons-0.97.ebuild21
-rw-r--r--dev-util/scons/scons-0.98.4.ebuild46
-rw-r--r--dev-util/scons/scons-0.98.5.ebuild46
-rw-r--r--dev-util/scons/scons-1.0.0.ebuild (renamed from dev-util/scons/scons-0.98.3.ebuild)23
5 files changed, 28 insertions, 118 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index c35a3e30e0eb..acc4bb531083 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/scons
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.58 2008/07/19 12:31:48 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.59 2008/08/20 04:26:40 neurogeek Exp $
+
+*scons-1.0.0 (19 Aug 2008)
+
+ 19 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> scons-0.97.ebuild,
+ -scons-0.98.3.ebuild, -scons-0.98.4.ebuild, -scons-0.98.5.ebuild,
+ +scons-1.0.0.ebuild:
+ Version bump. Removed old versions. Fixed 0.97 ebuild and this closes bug
+ #223527
*scons-0.98.5 (19 Jul 2008)
diff --git a/dev-util/scons/scons-0.97.ebuild b/dev-util/scons/scons-0.97.ebuild
index 3ef736df4115..4907cb91b0ee 100644
--- a/dev-util/scons/scons-0.97.ebuild
+++ b/dev-util/scons/scons-0.97.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.97.ebuild,v 1.10 2008/06/14 11:45:06 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.97.ebuild,v 1.11 2008/08/20 04:26:40 neurogeek Exp $
NEED_PYTHON="1.5.2"
-inherit python distutils multilib
+inherit distutils
DESCRIPTION="Extensible Python-based build utility"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -25,20 +25,17 @@ src_install () {
}
pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.96.92-r1"
- clean_stale_junk=$?
+ # clean up stale junk left there by old faulty ebuilds
+ # see Bug 118022 and Bug 132448 and Bug 107013
+ einfo "Cleaning up stale orphaned py[co] files..."
+ einfo "Checking for /usr/lib/${P}/SCons"
+ [[ -d "${ROOT}/usr/$(get_libdir)/${P}/SCons" ]] \
+ && rm -rf "${ROOT}/usr/$(get_libdir)/${P}/SCons"
+ einfo "Done."
}
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${P}
- # clean up stale junk left there by old faulty ebuilds
- # see Bug 118022 and Bug 132448
- if [[ $clean_stale_junk = 0 ]] ; then
- einfo "Cleaning up stale orphaned py[co] files..."
- [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
- && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
- einfo "Done."
- fi
}
pkg_postrm() {
diff --git a/dev-util/scons/scons-0.98.4.ebuild b/dev-util/scons/scons-0.98.4.ebuild
deleted file mode 100644
index 2548d77dd372..000000000000
--- a/dev-util/scons/scons-0.98.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.4.ebuild,v 1.2 2008/06/14 11:45:06 zmedico Exp $
-
-NEED_PYTHON="1.5.2"
-
-inherit python distutils multilib
-
-DESCRIPTION="Extensible Python-based build utility"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.scons.org/"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
-
-src_install () {
- distutils_src_install
- # move man pages from /usr/man to /usr/share/man
- dodir /usr/share
- mv "${D}"/usr/man "${D}"/usr/share
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.96.92-r1"
- clean_stale_junk=$?
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/$(get_libdir)/${P}
- # clean up stale junk left there by old faulty ebuilds
- # see Bug 118022 and Bug 132448
- if [[ $clean_stale_junk = 0 ]] ; then
- einfo "Cleaning up stale orphaned py[co] files..."
- [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
- && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
- einfo "Done."
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/${P}
-}
diff --git a/dev-util/scons/scons-0.98.5.ebuild b/dev-util/scons/scons-0.98.5.ebuild
deleted file mode 100644
index e16e5721df54..000000000000
--- a/dev-util/scons/scons-0.98.5.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.5.ebuild,v 1.1 2008/07/19 12:31:48 hawking Exp $
-
-NEED_PYTHON="1.5.2"
-
-inherit python distutils multilib
-
-DESCRIPTION="Extensible Python-based build utility"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.scons.org/"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
-
-src_install () {
- distutils_src_install
- # move man pages from /usr/man to /usr/share/man
- dodir /usr/share
- mv "${D}"/usr/man "${D}"/usr/share
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.96.92-r1"
- clean_stale_junk=$?
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/$(get_libdir)/${P}
- # clean up stale junk left there by old faulty ebuilds
- # see Bug 118022 and Bug 132448
- if [[ $clean_stale_junk = 0 ]] ; then
- einfo "Cleaning up stale orphaned py[co] files..."
- [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
- && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
- einfo "Done."
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/${P}
-}
diff --git a/dev-util/scons/scons-0.98.3.ebuild b/dev-util/scons/scons-1.0.0.ebuild
index 95826a8dc747..2c90eb1f584e 100644
--- a/dev-util/scons/scons-0.98.3.ebuild
+++ b/dev-util/scons/scons-1.0.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.3.ebuild,v 1.2 2008/06/14 11:45:06 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-1.0.0.ebuild,v 1.1 2008/08/20 04:26:40 neurogeek Exp $
NEED_PYTHON="1.5.2"
-inherit python distutils multilib
+inherit distutils
DESCRIPTION="Extensible Python-based build utility"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.scons.org/"
SLOT="0"
-LICENSE="as-is"
+LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
@@ -25,20 +25,17 @@ src_install () {
}
pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.96.92-r1"
- clean_stale_junk=$?
+ # clean up stale junk left there by old faulty ebuilds
+ # see Bug 118022 and Bug 132448 and Bug 107013
+ einfo "Cleaning up stale orphaned py[co] files..."
+ einfo "Checking for /usr/lib/${P}/SCons"
+ [[ -d "${ROOT}/usr/$(get_libdir)/${P}/SCons" ]] \
+ && rm -rf "${ROOT}/usr/$(get_libdir)/${P}/SCons"
+ einfo "Done."
}
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${P}
- # clean up stale junk left there by old faulty ebuilds
- # see Bug 118022 and Bug 132448
- if [[ $clean_stale_junk = 0 ]] ; then
- einfo "Cleaning up stale orphaned py[co] files..."
- [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
- && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
- einfo "Done."
- fi
}
pkg_postrm() {