summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-08 18:26:10 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-08 18:26:10 +0000
commitf8541c85c5d54650f64d39bc1f6adafc8c09dfd9 (patch)
treef8cd87a946ed34a3c7656e3b1644c580683fbf9c /dev-vcs/cssc
parentMarking pecl-crack-0.4-r1 ~ppc for bug 349659 (diff)
downloadgentoo-2-f8541c85c5d54650f64d39bc1f6adafc8c09dfd9.tar.gz
gentoo-2-f8541c85c5d54650f64d39bc1f6adafc8c09dfd9.tar.bz2
gentoo-2-f8541c85c5d54650f64d39bc1f6adafc8c09dfd9.zip
Do not use valgrind even if installed (bug #351010).
(Portage version: 2.2.0_alpha14/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/cssc')
-rw-r--r--dev-vcs/cssc/ChangeLog8
-rw-r--r--dev-vcs/cssc/cssc-1.2.0.ebuild31
-rw-r--r--dev-vcs/cssc/cssc-1.3.0.ebuild8
3 files changed, 11 insertions, 36 deletions
diff --git a/dev-vcs/cssc/ChangeLog b/dev-vcs/cssc/ChangeLog
index 91490c7f3b32..a0c9b087a69b 100644
--- a/dev-vcs/cssc/ChangeLog
+++ b/dev-vcs/cssc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/cssc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/ChangeLog,v 1.6 2010/11/07 19:22:17 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/ChangeLog,v 1.7 2011/01/08 18:26:10 jer Exp $
+
+ 08 Jan 2011; Jeroen Roovers <jer@gentoo.org> -cssc-1.2.0.ebuild,
+ cssc-1.3.0.ebuild:
+ Do not use valgrind even if installed (bug #351010).
*cssc-1.3.0 (07 Nov 2010)
diff --git a/dev-vcs/cssc/cssc-1.2.0.ebuild b/dev-vcs/cssc/cssc-1.2.0.ebuild
deleted file mode 100644
index 3fabc7bcdd8f..000000000000
--- a/dev-vcs/cssc/cssc-1.2.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/cssc-1.2.0.ebuild,v 1.4 2010/11/07 19:22:17 jer Exp $
-
-EAPI="2"
-
-DESCRIPTION="CSSC is the GNU Project's replacement for SCCS"
-SRC_URI="mirror://gnu/${PN}/CSSC-${PV}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/cssc/"
-SLOT="0"
-LICENSE="GPL-3"
-S=${WORKDIR}/CSSC-${PV}
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-src_prepare() {
- # The large test takes a long time
- sed -i tests/Makefile.* \
- -e 's|\([[:space:]]\)test-large |\1|g' || die "sed failed"
-}
-
-src_configure() { econf --enable-binary; }
-
-src_compile() {
- emake all || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS ChangeLog AUTHORS || die "dodoc failed"
-}
diff --git a/dev-vcs/cssc/cssc-1.3.0.ebuild b/dev-vcs/cssc/cssc-1.3.0.ebuild
index 296c861fe339..3eda53fbba52 100644
--- a/dev-vcs/cssc/cssc-1.3.0.ebuild
+++ b/dev-vcs/cssc/cssc-1.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/cssc-1.3.0.ebuild,v 1.1 2010/11/07 19:22:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/cssc-1.3.0.ebuild,v 1.2 2011/01/08 18:26:10 jer Exp $
EAPI="2"
@@ -19,7 +19,9 @@ src_prepare() {
-e 's|\([[:space:]]\)test-large |\1|g' || die "sed failed"
}
-src_configure() { econf --enable-binary; }
+src_configure() {
+ econf --enable-binary --without-valgrind
+}
src_compile() {
emake all || die "emake failed"