summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-14 04:48:02 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-14 04:48:02 +0000
commit3436a20704695be150b5f029dd6b82913e8b92ee (patch)
treee0345b9ec1683cd2a92cb9611f4ab40733316100 /dev-vcs/git
parentAdd gles2 useflag (diff)
downloadgentoo-2-3436a20704695be150b5f029dd6b82913e8b92ee.tar.gz
gentoo-2-3436a20704695be150b5f029dd6b82913e8b92ee.tar.bz2
gentoo-2-3436a20704695be150b5f029dd6b82913e8b92ee.zip
Re-enable USE=-iconv support now that the bug originally disabling it was fixed in upstream, and make sure we default to USE=iconv so that unicode/etc... messages "just work" out of the box #355467 by Tom Lloyd.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog12
-rw-r--r--dev-vcs/git/git-1.7.8.1.ebuild16
-rw-r--r--dev-vcs/git/git-1.7.8.2.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.8.3.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.8.4.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.8.5.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.8.6.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.8.ebuild16
-rw-r--r--dev-vcs/git/git-1.7.9.1.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9.2.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9.3.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9.4.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9.7.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.9_rc2.ebuild14
-rw-r--r--dev-vcs/git/git-9999.ebuild14
16 files changed, 57 insertions, 169 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 07e2733792ac..ffeed8487987 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.131 2012/05/20 04:25:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.132 2012/06/14 04:48:02 vapier Exp $
+
+ 14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.8.1.ebuild,
+ git-1.7.8.2.ebuild, git-1.7.8.3.ebuild, git-1.7.8.4.ebuild,
+ git-1.7.8.5.ebuild, git-1.7.8.6.ebuild, git-1.7.8.ebuild, git-1.7.9.1.ebuild,
+ git-1.7.9.2.ebuild, git-1.7.9.3.ebuild, git-1.7.9.4.ebuild,
+ git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-1.7.9_rc2.ebuild, git-9999.ebuild:
+ Re-enable USE=-iconv support now that the bug originally disabling it was
+ fixed in upstream, and make sure we default to USE=iconv so that
+ unicode/etc... messages "just work" out of the box #355467 by Tom Lloyd.
*git-1.7.10.2 (20 May 2012)
@@ -2533,4 +2542,3 @@
15 Apr 2005; Carlos Silva <r3pek@gentoo.org> +metadata.xml:
Initial import
-
diff --git a/dev-vcs/git/git-1.7.8.1.ebuild b/dev-vcs/git/git-1.7.8.1.ebuild
index bdbc0393b94e..c289b48dfeea 100644
--- a/dev-vcs/git/git-1.7.8.1.ebuild
+++ b/dev-vcs/git/git-1.7.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.1.ebuild,v 1.1 2011/12/21 23:59:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.1.ebuild,v 1.2 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.2.ebuild b/dev-vcs/git/git-1.7.8.2.ebuild
index fa4b57ed30c3..01a8c90eef44 100644
--- a/dev-vcs/git/git-1.7.8.2.ebuild
+++ b/dev-vcs/git/git-1.7.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.2.ebuild,v 1.1 2012/01/02 04:12:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.2.ebuild,v 1.2 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.3.ebuild b/dev-vcs/git/git-1.7.8.3.ebuild
index d371fe874966..faa009a548c1 100644
--- a/dev-vcs/git/git-1.7.8.3.ebuild
+++ b/dev-vcs/git/git-1.7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.3.ebuild,v 1.1 2012/01/07 02:58:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.3.ebuild,v 1.2 2012/06/14 04:48:02 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.4.ebuild b/dev-vcs/git/git-1.7.8.4.ebuild
index 58b26891a8fd..731123dcafb6 100644
--- a/dev-vcs/git/git-1.7.8.4.ebuild
+++ b/dev-vcs/git/git-1.7.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.4.ebuild,v 1.1 2012/01/20 08:32:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.4.ebuild,v 1.2 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.5.ebuild b/dev-vcs/git/git-1.7.8.5.ebuild
index 7cdf9e34cf54..4c0ef3b48ee3 100644
--- a/dev-vcs/git/git-1.7.8.5.ebuild
+++ b/dev-vcs/git/git-1.7.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.5.ebuild,v 1.1 2012/02/28 02:08:40 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.5.ebuild,v 1.2 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.6.ebuild b/dev-vcs/git/git-1.7.8.6.ebuild
index 2186e4185e01..2afdb7e23362 100644
--- a/dev-vcs/git/git-1.7.8.6.ebuild
+++ b/dev-vcs/git/git-1.7.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.6.ebuild,v 1.2 2012/05/09 15:51:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.6.ebuild,v 1.3 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.8.ebuild b/dev-vcs/git/git-1.7.8.ebuild
index 5e28847e82ee..39f403e111f1 100644
--- a/dev-vcs/git/git-1.7.8.ebuild
+++ b/dev-vcs/git/git-1.7.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.ebuild,v 1.1 2011/12/03 01:57:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.8.ebuild,v 1.2 2012/06/14 04:48:02 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -138,11 +138,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -213,10 +209,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.1.ebuild b/dev-vcs/git/git-1.7.9.1.ebuild
index ea877e0ee3f9..64807cd79cff 100644
--- a/dev-vcs/git/git-1.7.9.1.ebuild
+++ b/dev-vcs/git/git-1.7.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.1.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.1.ebuild,v 1.3 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.2.ebuild b/dev-vcs/git/git-1.7.9.2.ebuild
index 083bbd71d720..263bcd5c50e8 100644
--- a/dev-vcs/git/git-1.7.9.2.ebuild
+++ b/dev-vcs/git/git-1.7.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.2.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.2.ebuild,v 1.3 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.3.ebuild b/dev-vcs/git/git-1.7.9.3.ebuild
index a9bce41b3ad4..b9f1bca812d0 100644
--- a/dev-vcs/git/git-1.7.9.3.ebuild
+++ b/dev-vcs/git/git-1.7.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.3.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.3.ebuild,v 1.3 2012/06/14 04:48:02 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.4.ebuild b/dev-vcs/git/git-1.7.9.4.ebuild
index 043eaddf3c87..63875669a0f6 100644
--- a/dev-vcs/git/git-1.7.9.4.ebuild
+++ b/dev-vcs/git/git-1.7.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.4.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.4.ebuild,v 1.3 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.7.ebuild b/dev-vcs/git/git-1.7.9.7.ebuild
index b03c14ac2660..1b69b471e0e5 100644
--- a/dev-vcs/git/git-1.7.9.7.ebuild
+++ b/dev-vcs/git/git-1.7.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.7.ebuild,v 1.1 2012/04/26 21:47:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.7.ebuild,v 1.2 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9.ebuild b/dev-vcs/git/git-1.7.9.ebuild
index def8190f32c9..434c188fdeda 100644
--- a/dev-vcs/git/git-1.7.9.ebuild
+++ b/dev-vcs/git/git-1.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.ebuild,v 1.3 2012/06/14 04:48:02 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.9_rc2.ebuild b/dev-vcs/git/git-1.7.9_rc2.ebuild
index 3c05eacc76ab..b69df564bc23 100644
--- a/dev-vcs/git/git-1.7.9_rc2.ebuild
+++ b/dev-vcs/git/git-1.7.9_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9_rc2.ebuild,v 1.4 2012/01/28 20:35:53 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9_rc2.ebuild,v 1.5 2012/06/14 04:48:02 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -143,11 +143,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
@@ -218,10 +214,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 650c2c068f3c..52278baa97c7 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.31 2012/05/20 04:25:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.32 2012/06/14 04:48:01 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -143,11 +143,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -220,10 +216,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream