summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-08-02 00:20:15 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-08-02 00:20:15 +0000
commitd85cb41ac338a13568f977c08de9df56742655b3 (patch)
treec2e9c2e7dc0e38b1984c7df06c085af57b151e5d /dev-vcs/git
parentLinux patch 3.12.26 (diff)
downloadgentoo-2-d85cb41ac338a13568f977c08de9df56742655b3.tar.gz
gentoo-2-d85cb41ac338a13568f977c08de9df56742655b3.tar.bz2
gentoo-2-d85cb41ac338a13568f977c08de9df56742655b3.zip
Version bump. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog8
-rw-r--r--dev-vcs/git/git-2.0.4.ebuild (renamed from dev-vcs/git/git-2.0.0-r2.ebuild)13
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 5c771f68a907..e3efa0ab0132 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.273 2014/08/01 10:41:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.274 2014/08/02 00:20:15 polynomial-c Exp $
+
+*git-2.0.4 (02 Aug 2014)
+
+ 02 Aug 2014; Lars Wendler <polynomial-c@gentoo.org> -git-2.0.0-r2.ebuild,
+ +git-2.0.4.ebuild:
+ Version bump. Removed old.
01 Aug 2014; Raúl Porcel <armin76@gentoo.org> git-1.8.5.5.ebuild:
ia64/sparc stable wrt #501662
diff --git a/dev-vcs/git/git-2.0.0-r2.ebuild b/dev-vcs/git/git-2.0.4.ebuild
index 366517933a11..93cd51dbb7fa 100644
--- a/dev-vcs/git/git-2.0.0-r2.ebuild
+++ b/dev-vcs/git/git-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.0.0-r2.ebuild,v 1.1 2014/07/07 03:56:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.0.4.ebuild,v 1.1 2014/08/02 00:20:15 polynomial-c Exp $
EAPI=5
@@ -22,7 +22,7 @@ DOC_VER=${MY_PV}
DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
HOMEPAGE="http://www.git-scm.com/"
if [[ ${PV} != *9999 ]]; then
- SRC_URI_SUFFIX="gz"
+ SRC_URI_SUFFIX="xz"
SRC_URI_GOOG="http://git-core.googlecode.com/files"
SRC_URI_KORG="mirror://kernel/software/scm/git"
SRC_URI="${SRC_URI_GOOG}/${MY_P}.tar.${SRC_URI_SUFFIX}
@@ -33,7 +33,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
${SRC_URI_GOOG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
else
SRC_URI=""
KEYWORDS=""
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi