summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-01 12:39:48 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-01 12:39:48 +0000
commit705f3804a490906c4c33aee0cb3ad27b369419ce (patch)
treec9003bbb7cf13bef864d93fff48eacaaa2ad7df6 /dev-vcs/gitg
parentnet-analyzer/linkchecker: Version Bump; drop USE in favour of optfeature; fix... (diff)
downloadgentoo-2-705f3804a490906c4c33aee0cb3ad27b369419ce.tar.gz
gentoo-2-705f3804a490906c4c33aee0cb3ad27b369419ce.tar.bz2
gentoo-2-705f3804a490906c4c33aee0cb3ad27b369419ce.zip
Add a proper REQUIRED_USE for libpeas compatibility, use python_setup() to use the correct implementation.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/ChangeLog6
-rw-r--r--dev-vcs/gitg/gitg-3.14.0.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index 6f194d7c4f6f..a824a10a8674 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.31 2014/11/24 15:41:03 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.32 2014/12/01 12:39:48 mgorny Exp $
+
+ 01 Dec 2014; Michał Górny <mgorny@gentoo.org> gitg-3.14.0.ebuild:
+ Add a proper REQUIRED_USE for libpeas compatibility, use python_setup() to use
+ the correct implementation.
24 Nov 2014; Alexandre Rostovtsev <tetromino@gentoo.org> gitg-3.14.0.ebuild:
Add python-3.4 support.
diff --git a/dev-vcs/gitg/gitg-3.14.0.ebuild b/dev-vcs/gitg/gitg-3.14.0.ebuild
index 11ac18e813c4..8dd9ef180739 100644
--- a/dev-vcs/gitg/gitg-3.14.0.ebuild
+++ b/dev-vcs/gitg/gitg-3.14.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-3.14.0.ebuild,v 1.2 2014/11/24 15:41:03 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-3.14.0.ebuild,v 1.3 2014/12/01 12:39:48 mgorny Exp $
EAPI=5
VALA_MIN_API_VERSION="0.20"
-PYTHON_COMPAT=( python{3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{3_3,3_4} )
inherit autotools gnome2 python-r1 vala
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug glade +python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
# test if unbundling of libgd is possible
# Currently it seems not to be (unstable API/ABI)
@@ -52,6 +52,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
src_prepare() {
sed \
-e '/CFLAGS/s:-g::g' \