summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-06 14:24:40 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-06 14:24:40 +0000
commit85ce615b6f4d2c4582b0e452df87ce0d7d2a555a (patch)
tree2bef5b60e08413ac612e3ddc2b7a066b360bef55 /dev-vcs/guilt
parentre-fix bindist icon installation (diff)
downloadgentoo-2-85ce615b6f4d2c4582b0e452df87ce0d7d2a555a.tar.gz
gentoo-2-85ce615b6f4d2c4582b0e452df87ce0d7d2a555a.tar.bz2
gentoo-2-85ce615b6f4d2c4582b0e452df87ce0d7d2a555a.zip
Move package from dev-util to dev-vcs, bug 56967. Version bump, remove old.
(Portage version: 2.2_rc63/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/guilt')
-rw-r--r--dev-vcs/guilt/ChangeLog50
-rw-r--r--dev-vcs/guilt/guilt-0.32.1.ebuild48
-rw-r--r--dev-vcs/guilt/guilt-0.32.2.ebuild49
-rw-r--r--dev-vcs/guilt/guilt-0.32.ebuild48
-rw-r--r--dev-vcs/guilt/metadata.xml8
5 files changed, 203 insertions, 0 deletions
diff --git a/dev-vcs/guilt/ChangeLog b/dev-vcs/guilt/ChangeLog
new file mode 100644
index 000000000000..d9f767c4b34b
--- /dev/null
+++ b/dev-vcs/guilt/ChangeLog
@@ -0,0 +1,50 @@
+# ChangeLog for dev-vcs/guilt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/guilt/ChangeLog,v 1.1 2010/03/06 14:24:40 ulm Exp $
+
+*guilt-0.32.2 (06 Mar 2010)
+
+ 06 Mar 2010; Ulrich Mueller <ulm@gentoo.org> +guilt-0.32.ebuild,
+ +guilt-0.32.1.ebuild, +guilt-0.32.2.ebuild, +metadata.xml:
+ Move package from dev-util to dev-vcs, bug 56967. Version bump, remove old.
+
+ 09 Aug 2009; nixnut <nixnut@gentoo.org> guilt-0.32.ebuild:
+ ppc stable #276090
+
+ 31 Jul 2009; <chainsaw@gentoo.org> guilt-0.32.ebuild:
+ Marked stable on AMD64 as requested by Mike "SpanKY" Friesinger
+ <vapier@gentoo.org> in bug #276090. Compile-tested on a dual hex-core
+ Opteron with USE="-doc".
+
+ 01 Jul 2009; Christian Faulhammer <fauli@gentoo.org> guilt-0.32.ebuild:
+ stable x86, bug 276090
+
+*guilt-0.32.1 (01 Jul 2009)
+
+ 01 Jul 2009; Mike Frysinger <vapier@gentoo.org> +guilt-0.32.1.ebuild:
+ Version bump.
+
+*guilt-0.32 (08 May 2009)
+
+ 08 May 2009; Mike Frysinger <vapier@gentoo.org> +guilt-0.32.ebuild:
+ Version bump.
+
+ 08 May 2009; Mike Frysinger <vapier@gentoo.org> guilt-0.30.ebuild:
+ Mark amd64/x86 stable.
+
+ 16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
+ Remove ingmar from metadata.xml (#202413)
+
+ 11 Jun 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ guilt-0.30.ebuild:
+ mark ~ppc (bug #218049)
+
+ 28 Apr 2008; Raúl Porcel <armin76@gentoo.org> guilt-0.30.ebuild:
+ Add ~ia64/~sparc wrt #218049
+
+*guilt-0.30 (16 Apr 2008)
+
+ 16 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org> +metadata.xml,
+ +guilt-0.30.ebuild:
+ Import from sunrise, thanks to Denis 'raeLLL' Cheng <crquan@gmail.com> for
+ the ebuild. Fixes bug 205931.
diff --git a/dev-vcs/guilt/guilt-0.32.1.ebuild b/dev-vcs/guilt/guilt-0.32.1.ebuild
new file mode 100644
index 000000000000..2b0d1643df9c
--- /dev/null
+++ b/dev-vcs/guilt/guilt-0.32.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/guilt/guilt-0.32.1.ebuild,v 1.1 2010/03/06 14:24:40 ulm Exp $
+
+DESCRIPTION="A series of bash scripts which add a quilt-like interface to git"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/jsipek/guilt/"
+SRC_URI="mirror://kernel/linux/kernel/people/jsipek/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-manpages-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="dev-util/git"
+DEPEND="${RDEPEND}
+ doc? ( app-text/asciidoc app-text/xmlto )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^PREFIX/s:=.*:=/usr:' \
+ -e "/^htmldir/s:=.*:=/usr/share/doc/${PF}/html:" \
+ -e "/^VERSION/s:=.*:=${PV}:" \
+ Makefile */Makefile || die
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C Documentation html || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc Documentation/{Contributing,Features,HOWTO,Requirements}
+ doman Documentation/*.[0-9] || die
+
+ if use doc ; then
+ dodir "/usr/share/doc/${PF}/html"
+ emake -C Documentation install-html DESTDIR="${D}" || die
+ fi
+}
diff --git a/dev-vcs/guilt/guilt-0.32.2.ebuild b/dev-vcs/guilt/guilt-0.32.2.ebuild
new file mode 100644
index 000000000000..75c505db5f52
--- /dev/null
+++ b/dev-vcs/guilt/guilt-0.32.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/guilt/guilt-0.32.2.ebuild,v 1.1 2010/03/06 14:24:40 ulm Exp $
+
+DESCRIPTION="A series of bash scripts which add a quilt-like interface to git"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/jsipek/guilt/"
+# create manpages with "make -C Documentation man"
+SRC_URI="mirror://kernel/linux/kernel/people/jsipek/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-manpages-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="dev-util/git"
+DEPEND="${RDEPEND}
+ doc? ( app-text/asciidoc app-text/xmlto )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^PREFIX/s:=.*:=/usr:' \
+ -e "/^htmldir/s:=.*:=/usr/share/doc/${PF}/html:" \
+ -e "/^VERSION/s:=.*:=${PV}:" \
+ Makefile */Makefile || die
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C Documentation html || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc Documentation/{Contributing,Features,HOWTO,Requirements}
+ doman Documentation/*.[0-9] || die
+
+ if use doc ; then
+ dodir "/usr/share/doc/${PF}/html"
+ emake -C Documentation install-html DESTDIR="${D}" || die
+ fi
+}
diff --git a/dev-vcs/guilt/guilt-0.32.ebuild b/dev-vcs/guilt/guilt-0.32.ebuild
new file mode 100644
index 000000000000..f5fbbe0aaa2d
--- /dev/null
+++ b/dev-vcs/guilt/guilt-0.32.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/guilt/guilt-0.32.ebuild,v 1.1 2010/03/06 14:24:40 ulm Exp $
+
+DESCRIPTION="A series of bash scripts which add a quilt-like interface to git"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/jsipek/guilt/"
+SRC_URI="mirror://kernel/linux/kernel/people/jsipek/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-manpages-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
+IUSE="doc"
+
+RDEPEND="dev-util/git"
+DEPEND="${RDEPEND}
+ doc? ( app-text/asciidoc app-text/xmlto )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^PREFIX/s:=.*:=/usr:' \
+ -e "/^htmldir/s:=.*:=/usr/share/doc/${PF}/html:" \
+ -e "/^VERSION/s:=.*:=${PV}:" \
+ Makefile */Makefile || die
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C Documentation html || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc Documentation/{Contributing,Features,HOWTO,Requirements}
+ doman Documentation/*.[0-9] || die
+
+ if use doc ; then
+ dodir "/usr/share/doc/${PF}/html"
+ emake -C Documentation install-html DESTDIR="${D}" || die
+ fi
+}
diff --git a/dev-vcs/guilt/metadata.xml b/dev-vcs/guilt/metadata.xml
new file mode 100644
index 000000000000..73420b6cf0f0
--- /dev/null
+++ b/dev-vcs/guilt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>