summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-02-02 10:10:54 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-02-02 10:10:54 +0000
commit4d72040994756aa60a5b352a0c2552c6d6a0b78f (patch)
tree9ae8c113b3dff4a5adc87cfe59e7abcb418498e2 /dev-vcs/hg-git
parentRemove old versions of hg-git (diff)
downloadgentoo-2-4d72040994756aa60a5b352a0c2552c6d6a0b78f.tar.gz
gentoo-2-4d72040994756aa60a5b352a0c2552c6d6a0b78f.tar.bz2
gentoo-2-4d72040994756aa60a5b352a0c2552c6d6a0b78f.zip
Version bump hg-git to 0.8.0
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-vcs/hg-git')
-rw-r--r--dev-vcs/hg-git/ChangeLog7
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-vcs/hg-git/ChangeLog b/dev-vcs/hg-git/ChangeLog
index fec87d3ccc7c..e0c65718966b 100644
--- a/dev-vcs/hg-git/ChangeLog
+++ b/dev-vcs/hg-git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hg-git
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.61 2015/02/02 10:07:57 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.62 2015/02/02 10:10:54 djc Exp $
+
+*hg-git-0.8.0 (02 Feb 2015)
+
+ 02 Feb 2015; Dirkjan Ochtman <djc@gentoo.org> +hg-git-0.8.0.ebuild:
+ Version bump hg-git to 0.8.0
02 Feb 2015; Dirkjan Ochtman <djc@gentoo.org> -hg-git-0.5.0-r1.ebuild,
-hg-git-0.6.0.ebuild, -hg-git-0.6.1.ebuild:
diff --git a/dev-vcs/hg-git/hg-git-0.8.0.ebuild b/dev-vcs/hg-git/hg-git-0.8.0.ebuild
new file mode 100644
index 000000000000..e6e665df1f46
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.8.0.ebuild,v 1.1 2015/02/02 10:10:54 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"