summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-01-15 22:18:22 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-01-15 22:18:22 +0000
commitdba863f9cda6e759ec9a9776d9c9354cda73fac8 (patch)
treed487e0858f9c4a59a204d371a6472113028f6716 /dev-vcs/hub
parentupdates (diff)
downloadgentoo-2-dba863f9cda6e759ec9a9776d9c9354cda73fac8.tar.gz
gentoo-2-dba863f9cda6e759ec9a9776d9c9354cda73fac8.tar.bz2
gentoo-2-dba863f9cda6e759ec9a9776d9c9354cda73fac8.zip
version bump (bug #498208, thx to Vikraman)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-vcs/hub')
-rw-r--r--dev-vcs/hub/ChangeLog9
-rw-r--r--dev-vcs/hub/hub-1.11.1.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
index 00f5add07398..cb311ec5b926 100644
--- a/dev-vcs/hub/ChangeLog
+++ b/dev-vcs/hub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hub
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.5 2013/12/25 20:59:14 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.6 2014/01/15 22:18:22 ottxor Exp $
+
+*hub-1.11.1 (15 Jan 2014)
+
+ 15 Jan 2014; Christoph Junghans <ottxor@gentoo.org> +hub-1.11.1.ebuild:
+ version bump (bug #498208, thx to Vikraman)
25 Dec 2013; Christoph Junghans <ottxor@gentoo.org> -hub-1.10.6.ebuild,
hub-1.11.0.ebuild:
diff --git a/dev-vcs/hub/hub-1.11.1.ebuild b/dev-vcs/hub/hub-1.11.1.ebuild
new file mode 100644
index 000000000000..7fe6d08a6c4e
--- /dev/null
+++ b/dev-vcs/hub/hub-1.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.1.ebuild,v 1.1 2014/01/15 22:18:22 ottxor Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit readme.gentoo ruby-fakegem
+
+ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+
+DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="dev-vcs/git"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+}