summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-01-11 08:43:47 +0000
committerSebastian Pipping <sping@gentoo.org>2011-01-11 08:43:47 +0000
commit976176eea20524a64c512eb5e0d99e5ed4c516e9 (patch)
tree084202267d20a133076a6eeadab8d4a5386db968 /dev-vcs/svn2git
parentx86 stable wrt bug #350970 (diff)
downloadgentoo-2-976176eea20524a64c512eb5e0d99e5ed4c516e9.tar.gz
gentoo-2-976176eea20524a64c512eb5e0d99e5ed4c516e9.tar.bz2
gentoo-2-976176eea20524a64c512eb5e0d99e5ed4c516e9.zip
dev-vcs/svn2git: Bump to 1.0.2.1
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/svn2git')
-rw-r--r--dev-vcs/svn2git/ChangeLog11
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.2.1-include-path.patch13
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.2.1-version.patch14
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.2.1.ebuild47
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild19
5 files changed, 96 insertions, 8 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 1c594c4da25b..00c843715390 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/svn2git
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.8 2010/11/02 10:13:07 sping Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.9 2011/01/11 08:43:47 sping Exp $
+
+*svn2git-1.0.2.1 (11 Jan 2011)
+
+ 11 Jan 2011; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.2.1.ebuild,
+ +files/svn2git-1.0.2.1-include-path.patch,
+ +files/svn2git-1.0.2.1-version.patch, svn2git-9999.ebuild:
+ Bump to 1.0.2.1, sync live ebuild
*svn2git-0_pre20101101 (02 Nov 2010)
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.2.1-include-path.patch b/dev-vcs/svn2git/files/svn2git-1.0.2.1-include-path.patch
new file mode 100644
index 000000000000..2349b3080835
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.2.1-include-path.patch
@@ -0,0 +1,13 @@
+--- src/src.pro 2011-01-11 09:02:15.696463807 +0100
++++ src/src.pro 2011-01-11 09:03:59.793959849 +0100
+@@ -3,8 +3,8 @@
+ # Automatically generated by qmake (2.01a) dim. dc. 23 13:49:28 2007
+ ######################################################################
+
+-SVN_INCLUDE = /usr/include/subversion-1 /usr/local/include/subversion-1
+-APR_INCLUDE = /usr/include/apr-1.0 /usr/include/apr-1 /usr/local/include/apr-1
++SVN_INCLUDE = /usr/include/subversion-1
++APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+ VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.2.1-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.2.1-version.patch
new file mode 100644
index 000000000000..0ca442bfc589
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.2.1-version.patch
@@ -0,0 +1,14 @@
+--- src/src.pro 2011-01-11 09:27:21.530166986 +0100
++++ src/src.pro 2011-01-11 09:30:55.743128934 +0100
+@@ -7,10 +7,7 @@
+ APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = "1.0.2-1-gebac099"
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
diff --git a/dev-vcs/svn2git/svn2git-1.0.2.1.ebuild b/dev-vcs/svn2git/svn2git-1.0.2.1.ebuild
new file mode 100644
index 000000000000..f48e100edebc
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.2.1.ebuild,v 1.1 2011/01/11 08:43:47 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+MY_PV="1.0.2-1-gebac099"
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ [ "$PV" != "9999" ] && epatch "${FILESDIR}"/${PN}-1.0.2.1-version.patch
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index ac59e306fbe9..a97dd08528f3 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.3 2010/06/22 18:51:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.4 2011/01/11 08:43:47 sping Exp $
EAPI="2"
-inherit qt4-r2
+inherit eutils qt4-r2
[ "$PV" == "9999" ] && inherit git
-DESCRIPTION="Importer for one time conversion from svn to git."
+MY_PV="1.0.2-1-gebac099"
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
HOMEPAGE="http://gitorious.org/svn2git/svn2git"
if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
KEYWORDS=""
else
- SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -27,8 +29,13 @@ DEPEND="dev-vcs/subversion
RDEPEND="${DEPEND}
dev-vcs/git"
+S=${WORKDIR}/${PN}-${PN}
+
src_prepare() {
- sed -i 's|^\(APR_INCLUDE = /usr/include/apr-1\)\.0|\1|' "${S}"/src/src.pro
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ [ "$PV" != "9999" ] && epatch "${FILESDIR}"/${PN}-1.0.2.1-version.patch
+
qt4-r2_src_prepare
}