summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-13 16:42:07 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-13 16:42:07 +0000
commit0fe58ef27f2c5875044b0f0f69079d5bf7223752 (patch)
tree42c4a7c1dd8fcf10f6e4ab37ce013d73e1b49a4b /dev-vcs/tig
parentAdding live ebuilds for SELinux policies (diff)
downloadgentoo-2-0fe58ef27f2c5875044b0f0f69079d5bf7223752.tar.gz
gentoo-2-0fe58ef27f2c5875044b0f0f69079d5bf7223752.tar.bz2
gentoo-2-0fe58ef27f2c5875044b0f0f69079d5bf7223752.zip
Version bump.
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-1.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index db45869daecf..449caa684875 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.17 2012/07/24 22:51:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.18 2012/10/13 16:42:07 radhermit Exp $
+
+*tig-1.1 (13 Oct 2012)
+
+ 13 Oct 2012; Tim Harder <radhermit@gentoo.org> +tig-1.1.ebuild:
+ Version bump.
24 Jul 2012; Tim Harder <radhermit@gentoo.org> -tig-0.18.ebuild:
Remove old.
diff --git a/dev-vcs/tig/tig-1.1.ebuild b/dev-vcs/tig/tig-1.1.ebuild
new file mode 100644
index 000000000000..d27184ff1f75
--- /dev/null
+++ b/dev-vcs/tig/tig-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.1.ebuild,v 1.1 2012/10/13 16:42:07 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS
+ dohtml manual.html README.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}