summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-11-07 20:39:34 +0000
committerMike Gilbert <floppym@gentoo.org>2011-11-07 20:39:34 +0000
commit087f04861d7253a8911e86e16a0f838dcb2d01e3 (patch)
treedd3f13e87c804d6d58af0c3875a6fee2a155e7ac /dev-vcs/tortoisehg
parentVersion bump. (diff)
downloadgentoo-2-087f04861d7253a8911e86e16a0f838dcb2d01e3.tar.gz
gentoo-2-087f04861d7253a8911e86e16a0f838dcb2d01e3.tar.bz2
gentoo-2-087f04861d7253a8911e86e16a0f838dcb2d01e3.zip
Version bump. Merge with live ebuild.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog8
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.2.ebuild69
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild17
3 files changed, 88 insertions, 6 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index d5cd99884ced..393965865f10 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.4 2011/11/04 19:17:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.5 2011/11/07 20:39:34 floppym Exp $
+
+*tortoisehg-2.2 (07 Nov 2011)
+
+ 07 Nov 2011; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.2.ebuild,
+ tortoisehg-9999.ebuild:
+ Version bump. Merge with live ebuild.
*tortoisehg-9999 (04 Nov 2011)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.2.ebuild
new file mode 100644
index 000000000000..9fb429d6ddef
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.2.ebuild,v 1.1 2011/11/07 20:39:34 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 74dc8787ed44..da96f87d1771 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.1 2011/11/04 19:17:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.2 2011/11/07 20:39:34 floppym Exp $
EAPI=4
@@ -8,16 +8,23 @@ SUPPORT_PYTHON_ABIS=1
PYTHON_DEPEND="2:2.5"
RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit distutils eutils mercurial multilib
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+fi
DESCRIPTION="Set of graphical tools for Mercurial"
HOMEPAGE="http://tortoisehg.bitbucket.org"
-SRC_URI=""
-EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="doc nautilus"
RDEPEND="dev-python/iniparse