summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-06 19:32:54 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-06 19:32:54 +0000
commit2e4533ea253c2015562f8010d86514d3de3e57dd (patch)
treeb37332b80716f4b3c5ed22795409cba9aa1769bd /dev-vcs
parentOnly require dev-libs/nss[utils] in RDEPEND. (diff)
downloadgentoo-2-2e4533ea253c2015562f8010d86514d3de3e57dd.tar.gz
gentoo-2-2e4533ea253c2015562f8010d86514d3de3e57dd.tar.bz2
gentoo-2-2e4533ea253c2015562f8010d86514d3de3e57dd.zip
Long overdue 1.8 bump (bug #474848)
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog11
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.0-hpux-dso.patch16
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch85
-rw-r--r--dev-vcs/subversion/subversion-1.8.5.ebuild468
4 files changed, 578 insertions, 2 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 8805b958a1c8..879b1feb0107 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/subversion
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.154 2013/12/29 11:57:12 tommy Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.155 2014/01/06 19:32:54 polynomial-c Exp $
+
+*subversion-1.8.5 (06 Jan 2014)
+
+ 06 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> +subversion-1.8.5.ebuild,
+ +files/subversion-1.8.0-hpux-dso.patch,
+ +files/subversion-1.8.1-revert_bdb6check.patch:
+ Long overdue 1.8 bump. Thanks to all contributiors in bug #474848.
29 Dec 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-subversion-1.7.13.ebuild:
diff --git a/dev-vcs/subversion/files/subversion-1.8.0-hpux-dso.patch b/dev-vcs/subversion/files/subversion-1.8.0-hpux-dso.patch
new file mode 100644
index 000000000000..92da0abf19de
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.0-hpux-dso.patch
@@ -0,0 +1,16 @@
+--- subversion-1.8.0/subversion/libsvn_ra/ra_loader.c
++++ subversion-1.8.0/subversion/libsvn_ra/ra_loader.c
+@@ -141,8 +141,13 @@
+ const char *compat_funcname;
+ apr_status_t status;
+
++#if defined(__hpux) && defined(__hppa)
++ libname = apr_psprintf(pool, "libsvn_ra_%s-%d.sl.%d",
++ ra_name, SVN_VER_MAJOR);
++#else
+ libname = apr_psprintf(pool, "libsvn_ra_%s-%d.so.%d",
+ ra_name, SVN_VER_MAJOR, SVN_SOVERSION);
++#endif
+ funcname = apr_psprintf(pool, "svn_ra_%s__init", ra_name);
+ compat_funcname = apr_psprintf(pool, "svn_ra_%s_init", ra_name);
+
diff --git a/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
new file mode 100644
index 000000000000..158c08233165
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
@@ -0,0 +1,85 @@
+--- subversion-1.8.1/build/ac-macros/berkeley-db.m4
++++ subversion-1.8.1/build/ac-macros/berkeley-db.m4
+@@ -48,7 +48,7 @@
+ AC_ARG_WITH(berkeley-db, [AS_HELP_STRING(
+ [[--with-berkeley-db[=HEADER:INCLUDES:LIB_SEARCH_DIRS:LIBS]]], [
+ The Subversion Berkeley DB based filesystem library
+- requires Berkeley DB $db_version or $db_alt_version. If you
++ requires Berkeley DB $db_version or newer. If you
+ specify `--without-berkeley-db', that library will
+ not be built. If you omit the argument of this option
+ completely, the configure script will use Berkeley DB
+@@ -126,35 +126,22 @@
+ svn_lib_berkeley_db=no
+ else
+ AC_MSG_CHECKING([for availability of Berkeley DB])
+- AC_ARG_ENABLE(bdb6,
+- AS_HELP_STRING([--enable-bdb6],
+- [Allow building against BDB 6+.
+- See --with-berkeley-db for specifying the location of
+- the Berkeley DB installation. Using BDB 6 will fail if
+- this option is not used.]),
+- [enable_bdb6=$enableval],[enable_bdb6=unspecified])
+-
+- SVN_LIB_BERKELEY_DB_TRY($1, $2, $3, $enable_bdb6)
++ SVN_LIB_BERKELEY_DB_TRY($1, $2, $3)
+ if test "$svn_have_berkeley_db" = "yes"; then
+ AC_MSG_RESULT([yes])
+ svn_lib_berkeley_db=yes
+ else
+- if test "$svn_have_berkeley_db" = "no6"; then
+- AC_MSG_RESULT([no (found version 6, but --enable-bdb6 not specified)])
+- # A warning will be printed at the end of configure.ac.
+- else
+- AC_MSG_RESULT([no])
+- fi
++ AC_MSG_RESULT([no])
+ svn_lib_berkeley_db=no
+ if test "$bdb_status" = "required"; then
+- AC_MSG_ERROR([Berkeley DB $db_version or $db_alt_version wasn't found.])
++ AC_MSG_ERROR([Berkeley DB $db_version or newer't found.])
+ fi
+ fi
+ fi
+ ])
+
+
+-dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch, enable_bdb6)
++dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch)
+ dnl
+ dnl A subroutine of SVN_LIB_BERKELEY_DB.
+ dnl
+@@ -187,7 +174,6 @@
+ svn_check_berkeley_db_major=$1
+ svn_check_berkeley_db_minor=$2
+ svn_check_berkeley_db_patch=$3
+- enable_bdb6=$4
+
+ if test -z "$SVN_DB_LIBS"; then
+ # We pass --dbm-libs here since Debian has modified apu-config not
+@@ -245,12 +231,6 @@
+ || patch != DB_VERSION_PATCH)
+ exit (1);
+
+- /* Block Berkeley DB 6, because (a) we haven't tested with it, (b) 6.0.20
+- and newer are under the AGPL, and we want use of AGPL dependencies to be
+- opt-in. */
+- if (major >= 6 && strcmp("$enable_bdb6", "yes"))
+- exit(2);
+-
+ /* Run-time check: ensure the library claims to be the correct version. */
+
+ if (major < $svn_check_berkeley_db_major)
+@@ -270,11 +250,7 @@
+ }
+ ]])],
+ [svn_have_berkeley_db=yes],
+- [rc=$?
+- svn_have_berkeley_db=no
+- if test $rc = 2; then
+- svn_have_berkeley_db=no6
+- fi],
++ [svn_have_berkeley_db=no],
+ [svn_have_berkeley_db=yes]
+ )
+
diff --git a/dev-vcs/subversion/subversion-1.8.5.ebuild b/dev-vcs/subversion/subversion-1.8.5.ebuild
new file mode 100644
index 000000000000..49f9a86e1198
--- /dev/null
+++ b/dev-vcs/subversion/subversion-1.8.5.ebuild
@@ -0,0 +1,468 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.5.ebuild,v 1.1 2014/01/06 19:32:53 polynomial-c Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_OPTIONAL=1
+WANT_AUTOMAKE="none"
+
+inherit autotools bash-completion-r1 db-use depend.apache distutils-r1 elisp-common flag-o-matic java-pkg-opt-2 libtool multilib perl-module eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Advanced version control system"
+HOMEPAGE="http://subversion.apache.org/"
+SRC_URI="mirror://apache/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Subversion GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring java kde nls perl python ruby sasl test vim-syntax +webdav-serf"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.7.12
+ >=dev-libs/apr-1.3:1
+ >=dev-libs/apr-util-1.3:1
+ dev-libs/expat
+ sys-libs/zlib
+ app-arch/bzip2
+ berkdb? ( >=sys-libs/db-4.0.14 )
+ ctypes-python? ( ${PYTHON_DEPS} )
+ gnome-keyring? ( dev-libs/glib:2 sys-apps/dbus gnome-base/gnome-keyring )
+ kde? ( sys-apps/dbus dev-qt/qtcore:4 dev-qt/qtdbus:4 dev-qt/qtgui:4 >=kde-base/kdelibs-4:4 )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( >=dev-lang/ruby-1.9.3:1.9
+ dev-ruby/rubygems[ruby_targets_ruby19] )
+ sasl? ( dev-libs/cyrus-sasl )
+ webdav-serf? ( >=net-libs/serf-1.2.1 )"
+RDEPEND="${COMMON_DEPEND}
+ apache2? ( www-servers/apache[apache2_modules_dav] )
+ java? ( >=virtual/jre-1.5 )
+ kde? ( kde-base/kwalletd )
+ nls? ( virtual/libintl )
+ perl? ( dev-perl/URI )"
+# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
+DEPEND="${COMMON_DEPEND}
+ test? ( ${PYTHON_DEPS} )
+ !!<sys-apps/sandbox-1.6
+ ctypes-python? ( dev-python/ctypesgen )
+ doc? ( app-doc/doxygen )
+ gnome-keyring? ( virtual/pkgconfig )
+ java? ( >=virtual/jdk-1.5 )
+ kde? ( virtual/pkgconfig )
+ nls? ( sys-devel/gettext )
+ webdav-serf? ( virtual/pkgconfig )"
+
+REQUIRED_USE="
+ ctypes-python? ( ${PYTHON_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )"
+
+want_apache
+
+pkg_setup() {
+ if use berkdb; then
+ local apu_bdb_version="$(${EPREFIX}/usr/bin/apu-1-config --includes \
+ | grep -Eoe '-I${EPREFIX}/usr/include/db[[:digit:]]\.[[:digit:]]' \
+ | sed 's:.*b::')"
+ einfo
+ if [[ -z "${SVN_BDB_VERSION}" ]]; then
+ if [[ -n "${apu_bdb_version}" ]]; then
+ SVN_BDB_VERSION="${apu_bdb_version}"
+ einfo "Matching db version to apr-util"
+ else
+ SVN_BDB_VERSION="$(db_ver_to_slot "$(db_findver sys-libs/db 2>/dev/null)")"
+ einfo "SVN_BDB_VERSION variable isn't set. You can set it to enforce using of specific version of Berkeley DB."
+ fi
+ fi
+ einfo "Using: Berkeley DB ${SVN_BDB_VERSION}"
+ einfo
+
+ if [[ -n "${apu_bdb_version}" && "${SVN_BDB_VERSION}" != "${apu_bdb_version}" ]]; then
+ eerror "APR-Util is linked against Berkeley DB ${apu_bdb_version}, but you are trying"
+ eerror "to build Subversion with support for Berkeley DB ${SVN_BDB_VERSION}."
+ eerror "Rebuild dev-libs/apr-util or set SVN_BDB_VERSION=\"${apu_bdb_version}\"."
+ eerror "Aborting to avoid possible run-time crashes."
+ die "Berkeley DB version mismatch"
+ fi
+ fi
+
+ depend.apache_pkg_setup
+
+ java-pkg-opt-2_pkg_setup
+
+ if ! use webdav-serf ; then
+ ewarn "WebDAV support is disabled. You need WebDAV to"
+ ewarn "access repositories through the HTTP protocol."
+ ewarn "Consider enabling \"webdav-serf\" USE flag"
+ echo -ne "\a"
+ fi
+
+ if use debug; then
+ append-cppflags -DSVN_DEBUG -DAP_DEBUG
+ fi
+
+ # Allow for custom repository locations.
+ SVN_REPOS_LOC="${SVN_REPOS_LOC:-${EPREFIX}/var/svn}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.4-interix.patch \
+ "${FILESDIR}"/${PN}-1.5.6-aix-dso.patch \
+ "${FILESDIR}"/${PN}-1.8.0-hpux-dso.patch \
+ "${FILESDIR}"/${PN}-fix-parallel-build-support-for-perl-bindings.patch \
+ "${FILESDIR}"/${PN}-1.8.1-revert_bdb6check.patch
+ epatch_user
+
+ fperms +x build/transform_libtool_scripts.sh
+
+ sed -i \
+ -e "s/\(BUILD_RULES=.*\) bdb-test\(.*\)/\1\2/g" \
+ -e "s/\(BUILD_RULES=.*\) test\(.*\)/\1\2/g" configure.ac
+
+ # this bites us in particular on Solaris
+ sed -i -e '1c\#!/usr/bin/env sh' build/transform_libtool_scripts.sh || \
+ die "/bin/sh is not POSIX shell!"
+
+ eautoconf
+ elibtoolize
+
+ sed -e 's/\(libsvn_swig_py\)-\(1\.la\)/\1-$(EPYTHON)-\2/g' \
+ -i build-outputs.mk || die "sed failed"
+
+ if use python; then
+ # XXX: make python_copy_sources accept path
+ S=${S}/subversion/bindings/swig/python python_copy_sources
+ rm -r "${S}"/subversion/bindings/swig/python || die
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ if use python || use perl || use ruby; then
+ myconf+=" --with-swig"
+ else
+ myconf+=" --without-swig"
+ fi
+
+ if use java; then
+ myconf+=" --without-junit"
+ fi
+
+ case ${CHOST} in
+ *-aix*)
+ # avoid recording immediate path to sharedlibs into executables
+ append-ldflags -Wl,-bnoipath
+ ;;
+ *-interix*)
+ # loader crashes on the LD_PRELOADs...
+ myconf+=" --disable-local-library-preloading"
+ ;;
+ *-solaris*)
+ # need -lintl to link
+ use nls && append-libs intl
+ # this breaks installation, on x64 echo replacement is 32-bits
+ myconf+=" --disable-local-library-preloading"
+ ;;
+ *-mint*)
+ myconf+=" --enable-all-static --disable-local-library-preloading"
+ ;;
+ *)
+ # inject LD_PRELOAD entries for easy in-tree development
+ myconf+=" --enable-local-library-preloading"
+ ;;
+ esac
+
+ #workaround for bug 387057
+ has_version =dev-vcs/subversion-1.6* && myconf+=" --disable-disallowing-of-undefined-references"
+
+ #version 1.7.7 again tries to link against the older installed version and fails, when trying to
+ #compile for x86 on amd64, so workaround this issue again
+ #check newer versions, if this is still/again needed
+ myconf+=" --disable-disallowing-of-undefined-references"
+
+ # for build-time scripts
+ if use ctypes-python || use python || use test; then
+ python_export_best
+ fi
+
+ #force ruby-1.8 for bug 399105
+ #allow overriding Python include directory
+ ac_cv_path_RUBY="${EPREFIX}"/usr/bin/ruby19 ac_cv_path_RDOC="${EPREFIX}"/usr/bin/rdoc19 \
+ ac_cv_python_includes='-I$(PYTHON_INCLUDEDIR)' \
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_with apache2 apache-libexecdir) \
+ $(use_with apache2 apxs "${APXS}") \
+ $(use_with berkdb berkeley-db "db.h:${EPREFIX}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}") \
+ $(use_with ctypes-python ctypesgen "${EPREFIX}/usr") \
+ $(use_enable dso runtime-module-search) \
+ $(use_with gnome-keyring) \
+ $(use_enable java javahl) \
+ $(use_with java jdk "${JAVA_HOME}") \
+ $(use_with kde kwallet) \
+ $(use_enable nls) \
+ $(use_with sasl) \
+ $(use_with webdav-serf serf "${EPREFIX}/usr") \
+ ${myconf} \
+ --with-apr="${EPREFIX}/usr/bin/apr-1-config" \
+ --with-apr-util="${EPREFIX}/usr/bin/apu-1-config" \
+ --disable-experimental-libtool \
+ --without-jikes \
+ --disable-mod-activation \
+ --disable-static
+}
+
+src_compile() {
+ emake local-all
+
+ if use ctypes-python; then
+ # pre-generate .py files
+ use ctypes-python && emake ctypes-python
+
+ pushd subversion/bindings/ctypes-python >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+
+ if use python; then
+ swig_py_compile() {
+ local p=subversion/bindings/swig/python
+ rm -f ${p} || die
+ ln -s "${BUILD_DIR}" ${p} || die
+
+ python_export PYTHON_INCLUDEDIR
+ emake swig-py \
+ swig_pydir="$(python_get_sitedir)/libsvn" \
+ swig_pydir_extra="$(python_get_sitedir)/svn"
+ }
+
+ # this will give us proper BUILD_DIR for symlinking
+ BUILD_DIR=python \
+ python_foreach_impl swig_py_compile
+ fi
+
+ if use perl; then
+ emake swig-pl
+ fi
+
+ if use ruby; then
+ emake swig-rb
+ fi
+
+ if use java; then
+ emake -j1 JAVAC_FLAGS="$(java-pkg_javac-args) -encoding iso8859-1" javahl
+ fi
+
+ if use extras; then
+ emake tools
+ fi
+
+ if use doc; then
+ doxygen doc/doxygen.conf || die "Building of Subversion HTML documentation failed"
+
+ if use java; then
+ emake doc-javahl
+ fi
+ fi
+}
+
+src_test() {
+ default
+
+ if use ctypes-python; then
+ python_test() {
+ "${PYTHON}" subversion/bindings/ctypes-python/test/run_all.py \
+ || die "ctypes-python tests fail with ${EPYTHON}"
+ }
+
+ distutils-r1_src_test
+ fi
+
+ if use python; then
+ swig_py_test() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ "${PYTHON}" tests/run_all.py || die "swig-py tests fail with ${EPYTHON}"
+ popd >/dev/null || die
+ }
+
+ BUILD_DIR=subversion/bindings/swig/python \
+ python_foreach_impl swig_py_test
+ fi
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" local-install
+
+ if use ctypes-python; then
+ pushd subversion/bindings/ctypes-python >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
+ fi
+
+ if use python; then
+ swig_py_install() {
+ local p=subversion/bindings/swig/python
+ rm -f ${p} || die
+ ln -s "${BUILD_DIR}" ${p} || die
+
+ emake \
+ DESTDIR="${D}" \
+ swig_pydir="$(python_get_sitedir)/libsvn" \
+ swig_pydir_extra="$(python_get_sitedir)/svn" \
+ install-swig-py
+ }
+
+ BUILD_DIR=python \
+ python_foreach_impl swig_py_install
+ fi
+
+ if use perl; then
+ emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl
+ fixlocalpod
+ find "${ED}" "(" -name .packlist -o -name "*.bs" ")" -delete
+ fi
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-swig-rb
+ fi
+
+ if use java; then
+ emake DESTDIR="${D}" install-javahl
+ java-pkg_regso "${ED}"usr/$(get_libdir)/libsvnjavahl*$(get_libname)
+ java-pkg_dojar "${ED}"usr/$(get_libdir)/svn-javahl/svn-javahl.jar
+ rm -fr "${ED}"usr/$(get_libdir)/svn-javahl/*.jar
+ fi
+
+ # Install Apache module configuration.
+ if use apache2; then
+ keepdir "${APACHE_MODULES_CONFDIR}"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/47_mod_dav_svn.conf"
+ fi
+
+ # Install Bash Completion, bug 43179.
+ newbashcomp tools/client-side/bash_completion subversion
+ rm -f tools/client-side/bash_completion
+
+ # Install hot backup script, bug 54304.
+ newbin tools/backup/hot-backup.py svn-hot-backup
+ rm -fr tools/backup
+
+ # Install svnserve init-script and xinet.d snippet, bug 43245.
+ newinitd "${FILESDIR}"/svnserve.initd2 svnserve
+ newconfd "${FILESDIR}"/svnserve.confd svnserve
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/svnserve.xinetd svnserve
+
+ #adjust default user and group with disabled apache2 USE flag, bug 381385
+ use apache2 || sed -e "s\USER:-apache\USER:-svn\g" \
+ -e "s\GROUP:-apache\GROUP:-svnusers\g" \
+ -i "${ED}"etc/init.d/svnserve || die
+ use apache2 || sed -e "0,/apache/s//svn/" \
+ -e "s:apache:svnusers:" \
+ -i "${ED}"etc/xinetd.d/svnserve || die
+
+ # Install documentation.
+ dodoc CHANGES COMMITTERS README
+ dodoc tools/xslt/svnindex.{css,xsl}
+ rm -fr tools/xslt
+
+ # Install extra files.
+ if use extras; then
+ cat << EOF > 80subversion-extras
+PATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ROOTPATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+EOF
+ doenvd 80subversion-extras
+
+ emake DESTDIR="${D}" toolsdir="/usr/$(get_libdir)/subversion/bin" install-tools || die "Installation of tools failed"
+
+ find tools "(" -name "*.bat" -o -name "*.in" -o -name ".libs" ")" -print0 | xargs -0 rm -fr
+ rm -fr tools/client-side/svnmucc
+ rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
+ rm -fr tools/{buildbot,dev,diff,po}
+
+ insinto /usr/share/${PN}
+ find tools -name '*.py' -exec sed -i -e '1s:python:&2:' {} + || die
+ doins -r tools
+ fi
+
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+
+ if use java; then
+ java-pkg_dojavadoc doc/javadoc
+ fi
+ fi
+
+ find "${ED}" '(' -name '*.la' ')' -print0 | xargs -0 rm -f
+
+ cd "${ED}"usr/share/locale
+ for i in * ; do
+ [[ $i == *$LINGUAS* ]] || { rm -r $i || die ; }
+ done
+}
+
+pkg_preinst() {
+ # Compare versions of Berkeley DB, bug 122877.
+ if use berkdb && [[ -f "${EROOT}usr/bin/svn" ]]; then
+ OLD_BDB_VERSION="$(scanelf -nq "${EROOT}usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ NEW_BDB_VERSION="$(scanelf -nq "${ED}usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ if [[ "${OLD_BDB_VERSION}" != "${NEW_BDB_VERSION}" ]]; then
+ CHANGED_BDB_VERSION="1"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+
+ if [[ -n "${CHANGED_BDB_VERSION}" ]]; then
+ ewarn "You upgraded from an older version of Berkeley DB and may experience"
+ ewarn "problems with your repository. Run the following commands as root to fix it:"
+ ewarn " db4_recover -h ${SVN_REPOS_LOC}/repos"
+ ewarn " chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
+ fi
+
+ ewarn "If you run subversion as a daemon, you will need to restart it to avoid module mismatches."
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}
+
+pkg_config() {
+ # Remember: Don't use ${EROOT}${SVN_REPOS_LOC} since ${SVN_REPOS_LOC}
+ # already has EPREFIX in it
+ einfo "Initializing the database in ${SVN_REPOS_LOC}..."
+ if [[ -e "${SVN_REPOS_LOC}/repos" ]]; then
+ echo "A Subversion repository already exists and I will not overwrite it."
+ echo "Delete \"${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
+ else
+ mkdir -p "${SVN_REPOS_LOC}/conf"
+
+ einfo "Populating repository directory..."
+ # Create initial repository.
+ "${EROOT}usr/bin/svnadmin" create "${SVN_REPOS_LOC}/repos"
+
+ einfo "Setting repository permissions..."
+ SVNSERVE_USER="$(. "${EROOT}etc/conf.d/svnserve"; echo "${SVNSERVE_USER}")"
+ SVNSERVE_GROUP="$(. "${EROOT}etc/conf.d/svnserve"; echo "${SVNSERVE_GROUP}")"
+ if use apache2; then
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="apache"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="apache"
+ else
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="svn"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="svnusers"
+ fi
+ chmod -Rf go-rwx "${SVN_REPOS_LOC}/conf"
+ chmod -Rf o-rwx "${SVN_REPOS_LOC}/repos"
+ echo "Please create \"${SVNSERVE_GROUP}\" group if it does not exist yet."
+ echo "Afterwards please create \"${SVNSERVE_USER}\" user with homedir \"${SVN_REPOS_LOC}\""
+ echo "and as part of the \"${SVNSERVE_GROUP}\" group if it does not exist yet."
+ echo "Finally, execute \"chown -Rf ${SVNSERVE_USER}:${SVNSERVE_GROUP} ${SVN_REPOS_LOC}/repos\""
+ echo "to finish the configuration."
+ fi
+}