summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-09-07 02:33:42 +0000
committerMike Gilbert <floppym@gentoo.org>2011-09-07 02:33:42 +0000
commit3c28ae8f5a91cade7062259d7f58bc02deb735ef (patch)
treebcb27b04c53b6376b7d169bcf0956c69b874f674 /dev-vcs
parentAdd gnulib sched fix from upstream for uClibc builds #323377 by Maksim Melnik... (diff)
downloadgentoo-2-3c28ae8f5a91cade7062259d7f58bc02deb735ef.tar.gz
gentoo-2-3c28ae8f5a91cade7062259d7f58bc02deb735ef.tar.bz2
gentoo-2-3c28ae8f5a91cade7062259d7f58bc02deb735ef.zip
New package, resolves bug 277383 by manny15. Thanks also to Arne Babenhauserheide, Denilson Sá, and Alphat-PC.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog11
-rw-r--r--dev-vcs/tortoisehg/metadata.xml12
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.1.3.ebuild60
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
new file mode 100644
index 000000000000..af13d0d1bbe3
--- /dev/null
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-vcs/tortoisehg
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.1 2011/09/07 02:33:42 floppym Exp $
+
+*tortoisehg-2.1.3 (07 Sep 2011)
+
+ 07 Sep 2011; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.1.3.ebuild,
+ +metadata.xml:
+ New package, resolves bug 277383 by manny15. Thanks also to Arne
+ Babenhauserheide, Denilson Sá, and Alphat-PC.
+
diff --git a/dev-vcs/tortoisehg/metadata.xml b/dev-vcs/tortoisehg/metadata.xml
new file mode 100644
index 000000000000..79e163399c46
--- /dev/null
+++ b/dev-vcs/tortoisehg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <use>
+ <flag name="nautilus">Integrate with <pkg>gnome-base/nautilus</pkg> file manager</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.1.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.1.3.ebuild
new file mode 100644
index 000000000000..13fb7774bce2
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.1.3.ebuild,v 1.1 2011/09/07 02:33:42 floppym Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO || die
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg || die
+ domenu contrib/${PN}.desktop || die
+
+ if ! use nautilus; then
+ rm -rf "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}