summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-11-04 17:44:04 +0000
committerMike Gilbert <floppym@gentoo.org>2011-11-04 17:44:04 +0000
commit65603caa0ea5ab1d1d2727844b704b4cfd7f819c (patch)
treed1a359c0cdcd3d97aabf36818c9c61b82b43d825 /dev-vcs
parentmedia-video/smplayer: Fix mplayer2[(lib)ass] dependency (bug #383945) (diff)
downloadgentoo-2-65603caa0ea5ab1d1d2727844b704b4cfd7f819c.tar.gz
gentoo-2-65603caa0ea5ab1d1d2727844b704b4cfd7f819c.tar.bz2
gentoo-2-65603caa0ea5ab1d1d2727844b704b4cfd7f819c.zip
Add patch for Mercurial 2 compat, bug 389513 by polynomial-c. EAPI=4.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog8
-rw-r--r--dev-vcs/tortoisehg/files/tortoisehg-2.1.4-mercurial-2.patch20
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.1.4-r1.ebuild64
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 32e71435239b..d1fd6ec44e95 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.2 2011/10/11 15:23:59 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.3 2011/11/04 17:44:04 floppym Exp $
+
+*tortoisehg-2.1.4-r1 (04 Nov 2011)
+
+ 04 Nov 2011; Mike Gilbert <floppym@gentoo.org>
+ +files/tortoisehg-2.1.4-mercurial-2.patch, +tortoisehg-2.1.4-r1.ebuild:
+ Add patch for Mercurial 2 compat, bug 389513 by polynomial-c. EAPI=4.
*tortoisehg-2.1.4 (11 Oct 2011)
diff --git a/dev-vcs/tortoisehg/files/tortoisehg-2.1.4-mercurial-2.patch b/dev-vcs/tortoisehg/files/tortoisehg-2.1.4-mercurial-2.patch
new file mode 100644
index 000000000000..3f3284263240
--- /dev/null
+++ b/dev-vcs/tortoisehg/files/tortoisehg-2.1.4-mercurial-2.patch
@@ -0,0 +1,20 @@
+# HG changeset patch
+# User Yuya Nishihara <yuya@tcha.org>
+# Date 1319557903 -32400
+# Node ID f3817a7abb17cb14bdbb428b63345fb2d17f0853
+# Parent 08559b0a658f824b99294ac12cd2e472f4cd5129
+hgversion: carry minor digit to major like 1.9 to 2.0
+
+diff --git a/tortoisehg/util/hgversion.py b/tortoisehg/util/hgversion.py
+--- a/tortoisehg/util/hgversion.py
++++ b/tortoisehg/util/hgversion.py
+@@ -26,8 +26,7 @@
+ vers = re.split(r'\.|-', v)[:2]
+ if vers == reqver or len(vers) < 2:
+ return
+- nextver = list(reqver)
+- nextver[1] = str(int(reqver[1])+1)
++ nextver = map(str, divmod(int(reqver[0]) * 10 + int(reqver[1]) + 1, 10))
+ if vers == nextver:
+ return
+ return (('This version of TortoiseHg requires Mercurial '
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.1.4-r1.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..92465770eaf7
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.1.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.1.4-r1.ebuild,v 1.1 2011/11/04 17:44:04 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # Bug 389513: Mercurial 2 compatibility.
+ epatch "${FILESDIR}/${P}-mercurial-2.patch"
+
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}