summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-15 03:24:39 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-15 03:24:39 +0000
commit662e3d6b3f4b18c4a758db522dca33dcb54a404b (patch)
tree3bc378beeca3547b48ad6284afb1951480dd3639 /dev-vcs
parentDrop openssl version checking. (diff)
downloadgentoo-2-662e3d6b3f4b18c4a758db522dca33dcb54a404b.tar.gz
gentoo-2-662e3d6b3f4b18c4a758db522dca33dcb54a404b.tar.bz2
gentoo-2-662e3d6b3f4b18c4a758db522dca33dcb54a404b.zip
Restrict pypy.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog6
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.2.2-r1.ebuild72
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild69
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.3.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild4
5 files changed, 9 insertions, 146 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index e3c32f0b0eb3..26c782e32769 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.11 2012/02/24 23:27:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.12 2012/03/15 03:24:39 floppym Exp $
+
+ 15 Mar 2012; Mike Gilbert <floppym@gentoo.org> -tortoisehg-2.2.2-r1.ebuild,
+ -tortoisehg-2.2.2.ebuild, tortoisehg-2.3.ebuild, tortoisehg-9999.ebuild:
+ Restrict pypy.
*tortoisehg-2.3 (24 Feb 2012)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.2.2-r1.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.2.2-r1.ebuild
deleted file mode 100644
index 0e4d657dd7f4..000000000000
--- a/dev-vcs/tortoisehg/tortoisehg-2.2.2-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.2.2-r1.ebuild,v 1.1 2012/02/12 02:16:09 floppym Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils eutils multilib
-
-if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-else
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
- KEYWORDS=""
- SRC_URI=""
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="http://tortoisehg.bitbucket.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc nautilus"
-
-RDEPEND="dev-python/iniparse
- dev-python/pygments
- dev-python/PyQt4
- dev-python/qscintilla-python
- >=dev-vcs/mercurial-2.0
- nautilus? ( dev-python/nautilus-python )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.3 )"
-
-src_prepare() {
- # make the install respect multilib.
- sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
-
- # Bump the required mercurial version range.
- epatch "${FILESDIR}/${P}-hgversion.patch"
-
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C doc html
- fi
-}
-
-src_install() {
- distutils_src_install
- dodoc doc/ReadMe*.txt doc/TODO
-
- if use doc ; then
- dohtml -r doc/build/html || die
- fi
-
- insinto /usr/share/icons/hicolor/scalable/apps
- newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
- domenu contrib/${PN}.desktop
-
- if ! use nautilus; then
- rm -r "${ED}usr/$(get_libdir)/nautilus" || die
- fi
-}
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild
deleted file mode 100644
index 9bf73aa0825c..000000000000
--- a/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild,v 1.1 2012/01/28 03:57:04 floppym Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils eutils multilib
-
-if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-else
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
- KEYWORDS=""
- SRC_URI=""
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="http://tortoisehg.bitbucket.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc nautilus"
-
-RDEPEND="dev-python/iniparse
- dev-python/pygments
- dev-python/PyQt4
- dev-python/qscintilla-python
- >=dev-vcs/mercurial-1.9
- nautilus? ( dev-python/nautilus-python )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.3 )"
-
-src_prepare() {
- # make the install respect multilib.
- sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
-
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C doc html
- fi
-}
-
-src_install() {
- distutils_src_install
- dodoc doc/ReadMe*.txt doc/TODO
-
- if use doc ; then
- dohtml -r doc/build/html || die
- fi
-
- insinto /usr/share/icons/hicolor/scalable/apps
- newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
- domenu contrib/${PN}.desktop
-
- if ! use nautilus; then
- rm -r "${ED}usr/$(get_libdir)/nautilus" || die
- fi
-}
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild
index d5e08287f046..d1088d21f9f6 100644
--- a/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild,v 1.1 2012/02/24 23:27:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild,v 1.2 2012/03/15 03:24:39 floppym Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
inherit distutils eutils multilib
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index a1e2497f7102..dcafedbe164f 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.4 2012/02/12 02:19:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.5 2012/03/15 03:24:39 floppym Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
inherit distutils eutils multilib