summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-01-16 19:30:06 +0000
committerFabian Groffen <grobian@gentoo.org>2014-01-16 19:30:06 +0000
commit9b4eee0806d2815c00074c0f3e2939fe3e72c511 (patch)
treeba17fc4a0814c461bd1ed9bd9880a49c3e7d671f /dev-vcs
parentMark s390/sh stable. (diff)
downloadgentoo-2-9b4eee0806d2815c00074c0f3e2939fe3e72c511.tar.gz
gentoo-2-9b4eee0806d2815c00074c0f3e2939fe3e72c511.tar.bz2
gentoo-2-9b4eee0806d2815c00074c0f3e2939fe3e72c511.zip
Fix compilation on Solaris, help it find a proper python on Darwin
(Portage version: 2.2.8-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog5
-rw-r--r--dev-vcs/subversion/subversion-1.8.5.ebuild22
2 files changed, 25 insertions, 2 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 1a00578545a8..33164f44842f 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.159 2014/01/08 10:09:27 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.160 2014/01/16 19:30:06 grobian Exp $
+
+ 16 Jan 2014; Fabian Groffen <grobian@gentoo.org> subversion-1.8.5.ebuild:
+ Fix compilation on Solaris, help it find a proper python on Darwin
08 Jan 2014; Lars Wendler <polynomial-c@gentoo.org>
files/subversion-1.8.0-hpux-dso.patch:
diff --git a/dev-vcs/subversion/subversion-1.8.5.ebuild b/dev-vcs/subversion/subversion-1.8.5.ebuild
index 0606fd8f065c..dab0c2e0d3d4 100644
--- a/dev-vcs/subversion/subversion-1.8.5.ebuild
+++ b/dev-vcs/subversion/subversion-1.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.5.ebuild,v 1.3 2014/01/08 09:42:20 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.5.ebuild,v 1.4 2014/01/16 19:30:06 grobian Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -103,6 +103,9 @@ pkg_setup() {
append-cppflags -DSVN_DEBUG -DAP_DEBUG
fi
+ # http://mail-archives.apache.org/mod_mbox/subversion-dev/201306.mbox/%3C51C42014.3060700@wandisco.com%3E
+ [[ ${CHOST} == *-solaris2* ]] && append-cppflags -D__EXTENSIONS__
+
# Allow for custom repository locations.
SVN_REPOS_LOC="${SVN_REPOS_LOC:-${EPREFIX}/var/svn}"
}
@@ -125,6 +128,23 @@ src_prepare() {
sed -i -e '1c\#!/usr/bin/env sh' build/transform_libtool_scripts.sh || \
die "/bin/sh is not POSIX shell!"
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # replace provided script that tries too hard to do a framework
+ # build, ending up with host-provided Python
+ cat > build/get-py-info.py << EOS
+import sys
+import sysconfig
+if '--compile' in sys.argv:
+ print('${CHOST}-gcc')
+
+if '--libs' in sys.argv or '--link' in sys.argv:
+ libs = sysconfig.get_config_var('LIBS').split() + sysconfig.get_config_var('SYSLIBS').split()
+ libs.append('-lpython' + sysconfig.get_config_var('VERSION'))
+ print(' '.join(libs))
+EOS
+ fperms +x build/get-py-info.py
+ fi
+
eautoconf
elibtoolize