summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-11-24 05:29:49 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-11-24 05:29:49 +0000
commitaf6eea0f938de67e55d978c16c6875b3dcfc4997 (patch)
tree8c2a806cc37f04f059cceecc40b6a5561112439c /dev-vcs
parentEnable vala by default for gitg (diff)
downloadgentoo-2-af6eea0f938de67e55d978c16c6875b3dcfc4997.tar.gz
gentoo-2-af6eea0f938de67e55d978c16c6875b3dcfc4997.tar.bz2
gentoo-2-af6eea0f938de67e55d978c16c6875b3dcfc4997.zip
Non-maintainer version bump for compatibility with current versions of libgit2-glib; see bug #514468.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitg/ChangeLog9
-rw-r--r--dev-vcs/gitg/gitg-0.3.2.ebuild3
-rw-r--r--dev-vcs/gitg/gitg-3.14.0.ebuild80
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index b8605d4c977d..6d36be508bb8 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.29 2014/04/26 06:02:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.30 2014/11/24 05:29:49 tetromino Exp $
+
+*gitg-3.14.0 (24 Nov 2014)
+
+ 24 Nov 2014; Alexandre Rostovtsev <tetromino@gentoo.org> gitg-0.3.2.ebuild,
+ +gitg-3.14.0.ebuild:
+ Non-maintainer version bump for compatibility with current versions of
+ libgit2-glib; see bug #514468.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gitg-0.2.6.ebuild:
drop old
diff --git a/dev-vcs/gitg/gitg-0.3.2.ebuild b/dev-vcs/gitg/gitg-0.3.2.ebuild
index ef92101aaec4..730799e30c1b 100644
--- a/dev-vcs/gitg/gitg-0.3.2.ebuild
+++ b/dev-vcs/gitg/gitg-0.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.3.2.ebuild,v 1.3 2014/04/05 20:49:13 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.3.2.ebuild,v 1.4 2014/11/24 05:29:49 tetromino Exp $
EAPI=5
@@ -29,6 +29,7 @@ RDEPEND="
>=dev-libs/gobject-introspection-0.10.1
dev-libs/libgit2[threads]
>=dev-libs/libgit2-glib-0.0.10
+ <dev-libs/libgit2-glib-0.0.16
>=dev-libs/libpeas-1.5.0[gtk]
>=gnome-base/gsettings-desktop-schemas-0.1.1
>=net-libs/webkit-gtk-2.2:3[introspection]
diff --git a/dev-vcs/gitg/gitg-3.14.0.ebuild b/dev-vcs/gitg/gitg-3.14.0.ebuild
new file mode 100644
index 000000000000..f4b0b5a87b7c
--- /dev/null
+++ b/dev-vcs/gitg/gitg-3.14.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-3.14.0.ebuild,v 1.1 2014/11/24 05:29:49 tetromino Exp $
+
+EAPI=5
+
+VALA_MIN_API_VERSION="0.20"
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit autotools gnome2 python-r1 vala
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug glade +python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# test if unbundling of libgd is possible
+# Currently it seems not to be (unstable API/ABI)
+RDEPEND="
+ dev-libs/libgee:0.8[introspection]
+ >=dev-libs/json-glib-0.16
+ >=app-text/gtkspell-3.0.3:3
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.10.1
+ dev-libs/libgit2[threads]
+ >=dev-libs/libgit2-glib-0.0.20
+ >=dev-libs/libpeas-1.5.0[gtk]
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ >=net-libs/webkit-gtk-2.2:3[introspection]
+ >=x11-libs/gtk+-3.12.0:3
+ >=x11-libs/gtksourceview-3.10:3.0
+ >=x11-themes/gnome-icon-theme-symbolic-3.10
+ glade? ( >=dev-util/glade-3.2:3.10 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libgit2-glib[vala]
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ $(vala_depend)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed \
+ -e '/CFLAGS/s:-g::g' \
+ -e '/CFLAGS/s:-O0::g' \
+ -i configure.ac || die
+ eautoreconf
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ # Disable maintainer to get rid of -Werror (bug #363009)
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-deprecations
+ --disable-dependency-tracking
+ $(use_enable debug)
+ $(use_enable glade glade-catalog)
+ $(use_enable python)"
+
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install -j1
+}