summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-20 19:10:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-20 19:10:36 +0000
commit1b94bed61808b62e765a5720c3acb5f35f6ccdf8 (patch)
tree4a020c6c79bb93ccd5e1b1da93b1247231e7676b /eclass/autotools.eclass
parentDepend on proper qt with PKG_CONFIG_PATH support. (diff)
downloadgentoo-2-1b94bed61808b62e765a5720c3acb5f35f6ccdf8.tar.gz
gentoo-2-1b94bed61808b62e765a5720c3acb5f35f6ccdf8.tar.bz2
gentoo-2-1b94bed61808b62e765a5720c3acb5f35f6ccdf8.zip
Make sure that WANT_AUTOMAKE set in the ebuild is picked up by the automake wrapper (so that it's actually used as intended).
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index c55abfa80d0b..ce1784698626 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.42 2006/09/20 18:55:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.43 2006/09/20 19:10:36 flameeyes Exp $
#
# Author: Diego Pettenò <flameeyes@gentoo.org>
# Enhancements: Martin Schlemmer <azarah@gentoo.org>
@@ -152,6 +152,11 @@ eautomake() {
[[ -f Makefile.am ]] || return 0
+ if [[ -n ${WANT_AUTOMAKE} ]]; then
+ export WANT_AUTOMAKE # let the automake wrapper pick it up
+ einfo "Required automake ${WANT_AUTOMAKE}. Using $(automake --version | head -n 1)."
+ fi
+
if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then
local used_automake
local installed_automake