summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-07-29 13:45:05 +0000
committerDan Armak <danarmak@gentoo.org>2005-07-29 13:45:05 +0000
commite700ad6d90dfbec809741f5cf1898ed05828b185 (patch)
treeabaffd951e8eba5d787df19b90f65698e8d21007 /eclass/kde-meta.eclass
parentversion bump: Yahoo! chart format changed from jpg to png since May 2005 (diff)
downloadgentoo-2-e700ad6d90dfbec809741f5cf1898ed05828b185.tar.gz
gentoo-2-e700ad6d90dfbec809741f5cf1898ed05828b185.tar.bz2
gentoo-2-e700ad6d90dfbec809741f5cf1898ed05828b185.zip
check whether confcache_start, _stop are defined functions in order to avoid the (harmless) 'confcache_start not defined' error message
Diffstat (limited to 'eclass/kde-meta.eclass')
-rw-r--r--eclass/kde-meta.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/kde-meta.eclass b/eclass/kde-meta.eclass
index a1477d444934..3f822c43f365 100644
--- a/eclass/kde-meta.eclass
+++ b/eclass/kde-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.43 2005/07/29 08:34:59 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.44 2005/07/29 13:45:05 danarmak Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
# Simone Gotti <motaboy@gentoo.org>
@@ -392,12 +392,12 @@ function kde-meta_src_compile() {
if [ "$section" == "configure" ]; then
# don't log makefile.common stuff in confcache
[ ! -f "Makefile.in" ] && make -f admin/Makefile.common
- confcache_start
+ [ "`type -t confcache_start`" == "function" ] && confcache_start
myconf="$EXTRA_ECONF $myconf"
fi
kde_src_compile $section
if [ "$section" == "configure" ]; then
- confcache_stop
+ [ "`type -t confcache_stop`" == "function" ] && confcache_stop
fi
done
}