summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-03 20:03:10 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-03 20:03:10 +0000
commit05c1d186cba26147468f38718ec58811b85f55a7 (patch)
treec7cd995c1a4cf394fac2d78dd8975f7d1d73ab8d /eclass/poppler.eclass
parentBump version to use upstream tarball instead of gem. (diff)
downloadgentoo-2-05c1d186cba26147468f38718ec58811b85f55a7.tar.gz
gentoo-2-05c1d186cba26147468f38718ec58811b85f55a7.tar.bz2
gentoo-2-05c1d186cba26147468f38718ec58811b85f55a7.zip
Import patch from Debian http://bugs.debian.org/347650 which hacks around libtool deplib re-ordering, which inhibits -Wl,--as-needed. You have to set -Wl,--as-needed seperately in LDFLAGS for this to do any good, -Wl,--as-needed,--something-else will not do, but you can set -Wl,--something-else afterwards. Also make sure eclasses I 'own' run elibtoolize so they can reap the benefit.
Diffstat (limited to 'eclass/poppler.eclass')
-rw-r--r--eclass/poppler.eclass5
1 files changed, 3 insertions, 2 deletions
diff --git a/eclass/poppler.eclass b/eclass/poppler.eclass
index dc514876b044..1b553dfaf3c4 100644
--- a/eclass/poppler.eclass
+++ b/eclass/poppler.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/poppler.eclass,v 1.3 2009/04/10 23:18:41 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/poppler.eclass,v 1.4 2009/05/03 20:03:10 loki_val Exp $
# @ECLASS: poppler.eclass
# @MAINTAINER:
@@ -9,7 +9,7 @@
# @DESCRIPTION:
# Provides an easy template for making modularized poppler-based ebuilds.
-inherit base multilib
+inherit base multilib libtool
has 2 ${EAPI} || DEPEND="EAPI-TOO-OLD"
@@ -126,6 +126,7 @@ poppler_src_prepare() {
sed -i \
-e 's#$(top_builddir)/poppler/libpoppler.la#-lpoppler#' \
$(find . -type f -name 'Makefile.in') || die "Failed to sed proper lib into Makefile.am"
+ elibtoolize
}
# @FUNCTION: poppler_src_configure