summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-06-11 12:57:07 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-06-11 12:57:07 +0000
commit78be5ee8ef8274ecc19d2e4bdd07daf18105be96 (patch)
tree52048f27e142580c1d962a15ab4dd2dc6c75aa10 /eclass
parentversion bump as per bug #135522 (diff)
downloadgentoo-2-78be5ee8ef8274ecc19d2e4bdd07daf18105be96.tar.gz
gentoo-2-78be5ee8ef8274ecc19d2e4bdd07daf18105be96.tar.bz2
gentoo-2-78be5ee8ef8274ecc19d2e4bdd07daf18105be96.zip
restore kde eclass changes
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde-meta.eclass5
-rw-r--r--eclass/kde.eclass48
2 files changed, 25 insertions, 28 deletions
diff --git a/eclass/kde-meta.eclass b/eclass/kde-meta.eclass
index 16008e79053a..f8686f6a5acd 100644
--- a/eclass/kde-meta.eclass
+++ b/eclass/kde-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.75 2006/06/11 10:42:29 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.76 2006/06/11 12:57:07 carlo Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
# Simone Gotti <motaboy@gentoo.org>
@@ -367,9 +367,6 @@ function kde-meta_src_unpack() {
# Don't add a param here without looking at its implementation.
kde_src_unpack
- # revert for now
- kde_src_unpack autopatch
-
# kdebase: Remove the installation of the "startkde" script.
if [[ "$KMNAME" == "kdebase" ]]; then
sed -i -e s:"bin_SCRIPTS = startkde"::g ${S}/Makefile.am.in
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index 647388810616..26f82ac64887 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.166 2006/06/11 10:42:29 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.167 2006/06/11 12:57:07 carlo Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -87,32 +87,32 @@ kde_pkg_setup() {
kde_src_unpack() {
debug-print-function $FUNCNAME $*
-# local PATCHDIR="${WORKDIR}/patches/"
-# if [[ -z $* ]] ; then
-# # Unpack first and deal with KDE patches after examing possible patch sets.
-# # To be picked up, patches need to be named $PN-$PV-*{diff,patch} and be
-# # placed in $PATCHDIR. Monolithic ebuilds will use the split ebuild patches.
-# base_src_unpack unpack
-# if [[ -d "${PATCHDIR}" ]] ; then
-# if is-parent-package ${CATEGORY}/${PN} ; then
-# packages="$(get-child-packages ${CATEGORY}/${PN})"
-# packages="${packages//${CATEGORY}\//} ${PN}"
-# else
-# packages="${PN}"
-# fi
-# for _p in ${packages} ; do
-# PATCHES="${PATCHES} $(ls ${PATCHDIR}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
-# if [[ -n "${KDEBASE}" ]] ; then
-# PATCHES="${PATCHES} $(ls ${PATCHDIR}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
-# fi
-# done
-# fi
-# [[ -n ${PATCHES} ]] && base_src_unpack autopatch
-# else
+ local PATCHDIR="${WORKDIR}/patches/"
+ if [[ -z $* ]] ; then
+ # Unpack first and deal with KDE patches after examing possible patch sets.
+ # To be picked up, patches need to be named $PN-$PV-*{diff,patch} and be
+ # placed in $PATCHDIR. Monolithic ebuilds will use the split ebuild patches.
+ base_src_unpack unpack
+ if [[ -d "${PATCHDIR}" ]] ; then
+ if is-parent-package ${CATEGORY}/${PN} ; then
+ packages="$(get-child-packages ${CATEGORY}/${PN})"
+ packages="${packages//${CATEGORY}\//} ${PN}"
+ else
+ packages="${PN}"
+ fi
+ for _p in ${packages} ; do
+ PATCHES="${PATCHES} $(ls ${PATCHDIR}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
+ if [[ -n "${KDEBASE}" ]] ; then
+ PATCHES="${PATCHES} $(ls ${PATCHDIR}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
+ fi
+ done
+ fi
+ [[ -n ${PATCHES} ]] && base_src_unpack autopatch
+ else
# Call base_src_unpack, which has sections, to do unpacking and patching
# step by step transparently as defined in the ebuild.
base_src_unpack $*
-# fi
+ fi
[[ -z ${KDE_S} ]] && KDE_S="${S}"