summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-22 19:23:47 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-22 19:23:47 +0000
commit888bc773fa2740889734cd249e69fee92242e7ff (patch)
tree17cc1e845a20305947d09dc4f5136d058b8143c5 /eclass
parentMinimal edit to re-establish signature (diff)
downloadgentoo-2-888bc773fa2740889734cd249e69fee92242e7ff.tar.gz
gentoo-2-888bc773fa2740889734cd249e69fee92242e7ff.tar.bz2
gentoo-2-888bc773fa2740889734cd249e69fee92242e7ff.zip
Fix failing to pass default install arguments when user passes an additional command. Reported by radhermit.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass4
2 files changed, 7 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 4dfac4421043..455f1caf8edf 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1032 2013/10/22 15:16:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1033 2013/10/22 19:23:47 mgorny Exp $
+
+ 22 Oct 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Fix failing to pass default install arguments when user passes an additional
+ command. Reported by radhermit.
22 Oct 2013; Michał Górny <mgorny@gentoo.org> python-any-r1.eclass,
python-r1.eclass, python-single-r1.eclass:
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index bf5b650a667c..f7d2ef984d7a 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.88 2013/10/22 15:15:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.89 2013/10/22 19:23:47 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -492,7 +492,7 @@ distutils-r1_python_install() {
flags+=( --install-scripts="${PYTHON_SCRIPTDIR}" )
fi
- esetup.py install "${@}" "${flags[@]}"
+ esetup.py install "${@}" install "${flags[@]}"
if [[ -d ${root}$(python_get_sitedir)/tests ]]; then
die "Package installs 'tests' package, file collisions likely."