summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-22 23:46:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-22 23:46:19 +0000
commitdaedda259c8833431107d1f593dbdf87ad4cb112 (patch)
treed5874c70f7f447c40c1e62241219645c305cc865 /games-action/bzflag/bzflag-2.0.12.ebuild
parentUpdated SRC_URI and HOMEPAGE (Bug 259535) (diff)
downloadgentoo-2-daedda259c8833431107d1f593dbdf87ad4cb112.tar.gz
gentoo-2-daedda259c8833431107d1f593dbdf87ad4cb112.tar.bz2
gentoo-2-daedda259c8833431107d1f593dbdf87ad4cb112.zip
remove GAMES_USE_SDL; now handled by use-based deps
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-action/bzflag/bzflag-2.0.12.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.0.12.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/games-action/bzflag/bzflag-2.0.12.ebuild b/games-action/bzflag/bzflag-2.0.12.ebuild
index 3a28bf948de3..68f678e9a458 100644
--- a/games-action/bzflag/bzflag-2.0.12.ebuild
+++ b/games-action/bzflag/bzflag-2.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.8 2009/01/22 21:10:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.9 2009/02/22 23:46:19 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -16,7 +16,7 @@ IUSE="dedicated sdl"
UIDEPEND="virtual/opengl
virtual/glu
- || ( media-libs/libsdl[joystick] <media-libs/libsdl-1.2.13-r1 )
+ media-libs/libsdl[joystick]
media-libs/glew
x11-libs/libICE
x11-libs/libSM
@@ -35,12 +35,6 @@ DEPEND=">=net-misc/curl-7.15.0
sdl? ( ${UIDEPEND} )
!sdl? ( !dedicated? ( ${UIDEPEND} ) )"
-pkg_setup() {
- # Only do the libsdl checks for !dedicated - bug #107792
- use dedicated || GAMES_USE_SDL="nojoystick"
- games_pkg_setup
-}
-
src_configure() {
local myconf