summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-06-09 20:41:36 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-06-09 20:41:36 +0000
commit4395d7325e72af4108d7bff19521f832e9c9ed02 (patch)
treedb030a3d154e48bc00fe4943f38d984c32eb36ae /games-action/fakk2
parentAdded eutils to inherit. (diff)
downloadgentoo-2-4395d7325e72af4108d7bff19521f832e9c9ed02.tar.gz
gentoo-2-4395d7325e72af4108d7bff19521f832e9c9ed02.tar.bz2
gentoo-2-4395d7325e72af4108d7bff19521f832e9c9ed02.zip
Updated to use newer functions added since this ebuild was created.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-action/fakk2')
-rw-r--r--games-action/fakk2/ChangeLog5
-rw-r--r--games-action/fakk2/fakk2-1.02.ebuild19
2 files changed, 12 insertions, 12 deletions
diff --git a/games-action/fakk2/ChangeLog b/games-action/fakk2/ChangeLog
index 73b267cc61ec..85d53c07fd37 100644
--- a/games-action/fakk2/ChangeLog
+++ b/games-action/fakk2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/fakk2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.7 2005/04/20 14:09:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.8 2005/06/09 20:41:36 wolf31o2 Exp $
+
+ 09 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
+ Updated to use newer functions added since this ebuild was created.
20 Apr 2005; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
Added warning about bug #82149.
diff --git a/games-action/fakk2/fakk2-1.02.ebuild b/games-action/fakk2/fakk2-1.02.ebuild
index c7bbd16ff310..cc6fbf3a353d 100644
--- a/games-action/fakk2/fakk2-1.02.ebuild
+++ b/games-action/fakk2/fakk2-1.02.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.7 2005/04/20 14:09:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.8 2005/06/09 20:41:36 wolf31o2 Exp $
-inherit games
+inherit eutils games
IUSE="nocd"
DESCRIPTION="Heavy Metal: FAKK2 - 3D third-person action shooter based on the Heavy Metal comics/movies"
@@ -36,14 +36,14 @@ src_install() {
dodir ${dir}
einfo "Copying files... this may take a while..."
exeinto ${dir}
- doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk2
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
insinto ${dir}
doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
dodir ${dir}/fakk
- exeinto /opt/fakk2/fakk
+ exeinto ${dir}/fakk
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
if use nocd ; then
- insinto /opt/fakk2/fakk
+ insinto ${dir}fakk
doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
fi
@@ -52,14 +52,11 @@ src_install() {
# we run touch on ${D} so as to make sure portage doesnt do any such thing
find ${Ddir} -exec touch '{}' \;
- dodir ${GAMES_BINDIR}
- dogamesbin ${FILESDIR}/fakk2
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/fakk2
- insinto /usr/share/pixmaps
- newins ${CDROM_ROOT}/icon.xpm fakk2.xpm
+ games_make_wrapper ${PN} ./${PN} ${dir}
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
prepgamesdirs
- make_desktop_entry fakk2 "FAKK2" "fakk2.xpm"
+ make_desktop_entry ${PN} "FAKK2" ${PN}
}
pkg_postinst() {