summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commitf199057b8679cd2eed424fccb45361c89a133d31 (patch)
treee6ec41e59db82809cd99452c53c9efe67a3985e3 /games-action/gltron
parentgames action and arcade (diff)
downloadgentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.gz
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.bz2
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.zip
action games !
Diffstat (limited to 'games-action/gltron')
-rw-r--r--games-action/gltron/ChangeLog43
-rw-r--r--games-action/gltron/Manifest3
-rw-r--r--games-action/gltron/files/digest-gltron-0.621
-rw-r--r--games-action/gltron/gltron-0.62.ebuild34
4 files changed, 81 insertions, 0 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
new file mode 100644
index 000000000000..d1490a066048
--- /dev/null
+++ b/games-action/gltron/ChangeLog
@@ -0,0 +1,43 @@
+# ChangeLog for app-games/gltron
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+ 06 Jun 2003; Martin Holzer <mholzer@gentoo.org> gltron-0.62.ebuild:
+ Added sdl-sound to RDPEND. Closes #20158.
+
+*gltron-0.62 (03 Mar 2003)
+
+ 03 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + games eclass support #12428.
+
+*gltron-0.61-r2 (7 May 2002)
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> gltron-0.61-r2.ebuild :
+ Added KEYWORDS.
+ 7 May 2002; Spider <spider@gentoo.org> gltron-0.61-r2.ebuild gltron-0.61-r1.ebuild :
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> gltron-0.61-r1.ebuild :
+ Added KEYWORDS.
+ fix sourceforge mirroring.
+
+*gltron-0.61-r2 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> gltron-0.61-r2.ebuild :
+
+ Compile against newest libpng
+
+*gltron-0.61-r1 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> gltron-0.61-r1.ebuild :
+
+ HTML documentation will not get gzipped any more.
+
+*gltron-0.61 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-action/gltron/Manifest b/games-action/gltron/Manifest
new file mode 100644
index 000000000000..c6c20c3c8939
--- /dev/null
+++ b/games-action/gltron/Manifest
@@ -0,0 +1,3 @@
+MD5 7b9287ed2d521a7a4cf10f4fb6effb87 ChangeLog 1569
+MD5 516e5276b7e99af7f2e26610b79ffb93 gltron-0.62.ebuild 762
+MD5 3c3a2ca79ec73b429fa5f12310fccdbd files/digest-gltron-0.62 71
diff --git a/games-action/gltron/files/digest-gltron-0.62 b/games-action/gltron/files/digest-gltron-0.62
new file mode 100644
index 000000000000..5460e4b98a72
--- /dev/null
+++ b/games-action/gltron/files/digest-gltron-0.62
@@ -0,0 +1 @@
+MD5 cb62b09c39bd3f246432fa390e5e4881 gltron-0.62-source.tar.gz 3726643
diff --git a/games-action/gltron/gltron-0.62.ebuild b/games-action/gltron/gltron-0.62.ebuild
new file mode 100644
index 000000000000..e3d6d0656ecf
--- /dev/null
+++ b/games-action/gltron/gltron-0.62.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.62.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="3d tron, just like the movie"
+SRC_URI="mirror://sourceforge/gltron/${P}-source.tar.gz"
+HOMEPAGE="http://gltron.sourceforge.net/"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ sys-libs/zlib
+ media-libs/libpng"
+RDEPEND="${DEPEND}
+ media-libs/sdl-sound"
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc CREDITS ChangeLog FAQ README TODO
+ dohtml *.html
+ prepgamesdirs
+}