summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 19:03:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 19:03:08 +0000
commitaa8fce28c0339b716a1a87c486c9ecb04fa81b8b (patch)
treea9bfe758ba7ac2fb17660881851a19466d0ef65f /games-action/maelstrom
parentFixes #100360. (diff)
downloadgentoo-2-aa8fce28c0339b716a1a87c486c9ecb04fa81b8b.tar.gz
gentoo-2-aa8fce28c0339b716a1a87c486c9ecb04fa81b8b.tar.bz2
gentoo-2-aa8fce28c0339b716a1a87c486c9ecb04fa81b8b.zip
tidy; use DESTDIR; quoting
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-action/maelstrom')
-rw-r--r--games-action/maelstrom/ChangeLog6
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r1.ebuild57
2 files changed, 33 insertions, 30 deletions
diff --git a/games-action/maelstrom/ChangeLog b/games-action/maelstrom/ChangeLog
index be8801249186..b8d6f6c67cdc 100644
--- a/games-action/maelstrom/ChangeLog
+++ b/games-action/maelstrom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/maelstrom
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.16 2005/08/15 18:11:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.17 2005/08/15 19:03:08 mr_bones_ Exp $
+
+ 15 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ maelstrom-3.0.6-r1.ebuild:
+ tidy; use DESTDIR; quoting
15 Aug 2005; Chris Gianelloni <wolf31o2@gentoo.org>
maelstrom-3.0.6-r1.ebuild:
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
index e0b4bc3016aa..8193c59d9898 100644
--- a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
+++ b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
@@ -1,62 +1,61 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.7 2005/08/15 18:11:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.8 2005/08/15 19:03:08 mr_bones_ Exp $
inherit eutils games
MY_P=Maelstrom-${PV}
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="An asteroids battle game"
SRC_URI="http://www.devolution.com/~slouken/Maelstrom/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.devolution.com/~slouken/Maelstrom/"
-KEYWORDS="x86 ppc alpha amd64"
+KEYWORDS="alpha amd64 ppc x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
-RDEPEND=">=media-libs/libsdl-1.1.5
+DEPEND=">=media-libs/libsdl-1.1.5
>=media-libs/sdl-net-1.2.2"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/${PF}-security.patch
+ cd "${S}"
- # gcc-34 fix
- epatch ${FILESDIR}/${PN}-gcc34.patch
+ epatch \
+ "${FILESDIR}"/${PF}-security.patch \
+ "${FILESDIR}"/${PN}-gcc34.patch
# Install the data into $(datadir)/..., not $(prefix)/games/...
sed -i \
- -e "s:(prefix)/games/:(datadir)/:" configure || \
- die "sed configure failed"
+ -e "s:(prefix)/games/:(datadir)/:" configure \
+ || die "sed failed"
+ sed -i \
+ -e '/make install_gamedata/s:=:=$(DESTDIR)/:' \
+ Makefile.in \
+ || die "sed failed"
# Install the high scores file in ${GAMES_STATEDIR}
sed -i \
- -e "s:path.Path(MAELSTROM_SCORES):\"${GAMES_STATEDIR}/\"MAELSTROM_SCORES:" scores.cpp || \
- die "sed scores.cpp failed"
+ -e "s:path.Path(MAELSTROM_SCORES):\"${GAMES_STATEDIR}/\"MAELSTROM_SCORES:" \
+ scores.cpp \
+ || die "sed failed"
}
src_install() {
- egamesinstall || die
- dodoc Changelog README* Docs/{Maelstrom-Announce,*FAQ,MaelstromGPL_press_release,*.Paper,Technical_Notes*} || \
- die "dodoc failed"
- insinto /usr/share/pixmaps
- newins ${D}${GAMES_DATADIR}/Maelstrom/icon.xpm maelstrom.xpm || \
- die "newins failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README* Docs/{Maelstrom-Announce,*FAQ,MaelstromGPL_press_release,*.Paper,Technical_Notes*}
+ newicon "${D}${GAMES_DATADIR}"/Maelstrom/icon.xpm maelstrom.xpm
make_desktop_entry Maelstrom "Maelstrom" maelstrom.xpm
# Put the high scores file in the right place
- insinto ${GAMES_STATEDIR}
- doins ${D}${GAMES_DATADIR}/Maelstrom/Maelstrom-Scores || die "doins failed"
- rm -f ${D}${GAMES_DATADIR}/Maelstrom/Maelstrom-Scores
-
+ insinto "${GAMES_STATEDIR}"
+ doins "${D}${GAMES_DATADIR}"/Maelstrom/Maelstrom-Scores || die "doins failed"
# clean up some cruft
- rm -f ${D}${GAMES_DATADIR}/Maelstrom/Images/Makefile*
- prepgamesdirs
-
+ rm -f \
+ "${D}${GAMES_DATADIR}"/Maelstrom/Maelstrom-Scores \
+ "${D}${GAMES_DATADIR}"/Maelstrom/Images/Makefile*
# make sure we can update the high scores
- fperms 664 ${GAMES_STATEDIR}/Maelstrom-Scores || die "fperms failed"
+ fperms 664 "${GAMES_STATEDIR}"/Maelstrom-Scores || die "fperms failed"
+ prepgamesdirs
}