summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-11 23:47:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-11 23:47:13 +0000
commitd706461585bf53ddae93c0546b809ebb004d60b8 (patch)
tree99d30615b5183299c2ecc2556ccbdb736463a68e /games-action/openclonk
parentx11-libs/cairo: Disable automagic dependency on valgrind (diff)
downloadgentoo-2-d706461585bf53ddae93c0546b809ebb004d60b8.tar.gz
gentoo-2-d706461585bf53ddae93c0546b809ebb004d60b8.tar.bz2
gentoo-2-d706461585bf53ddae93c0546b809ebb004d60b8.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action/openclonk')
-rw-r--r--games-action/openclonk/ChangeLog9
-rw-r--r--games-action/openclonk/openclonk-5.3.3.ebuild113
2 files changed, 120 insertions, 2 deletions
diff --git a/games-action/openclonk/ChangeLog b/games-action/openclonk/ChangeLog
index 9f0bf4717166..091e87bf7356 100644
--- a/games-action/openclonk/ChangeLog
+++ b/games-action/openclonk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/openclonk
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openclonk/ChangeLog,v 1.7 2012/07/29 12:00:46 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/openclonk/ChangeLog,v 1.8 2013/03/11 23:47:13 hasufell Exp $
+
+*openclonk-5.3.3 (11 Mar 2013)
+
+ 11 Mar 2013; Julian Ospald <hasufell@gentoo.org> +openclonk-5.3.3.ebuild:
+ version bump
29 Jul 2012; Julian Ospald <hasufell@gentoo.org> openclonk-5.2.2.ebuild,
+files/openclonk-5.2.2-zlib-1.2.6.patch:
diff --git a/games-action/openclonk/openclonk-5.3.3.ebuild b/games-action/openclonk/openclonk-5.3.3.ebuild
new file mode 100644
index 000000000000..10930bd06b41
--- /dev/null
+++ b/games-action/openclonk/openclonk-5.3.3.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/openclonk/openclonk-5.3.3.ebuild,v 1.1 2013/03/11 23:47:13 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit autotools eutils flag-o-matic gnome2-utils python-any-r1 games
+
+MY_P=${PN}-release-${PV}-src
+
+DESCRIPTION="A free multiplayer action game where you control clonks"
+HOMEPAGE="http://openclonk.org/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://${PN}.org/homepage/icon.png -> ${PN}.png"
+
+LICENSE="BSD ISC CLONK-trademark LGPL-2.1 POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated doc mp3 sound upnp"
+
+RDEPEND="
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/jpeg
+ !dedicated? (
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libsdl[X,opengl,video]
+ virtual/opengl
+ virtual/glu
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libXrandr
+ x11-libs/libX11
+ sound? (
+ media-libs/libsdl[audio]
+ media-libs/sdl-mixer[mp3?,vorbis,wav]
+ )
+ )
+ dedicated? ( sys-libs/readline:0 )
+ upnp? ( net-libs/libupnp )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40
+ virtual/pkgconfig
+ doc? (
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python]
+ sys-devel/gettext
+ )"
+
+pkg_setup() {
+ games_pkg_setup
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # remove license files
+ sed \
+ -e '/dist_doc_DATA/s#planet/COPYING ##' \
+ -e '/dist_doc_DATA/s#licenses/LGPL.txt ##' \
+ -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable dedicated console) \
+ $(use_enable sound) \
+ $(use_enable mp3) \
+ $(usex dedicated "--with-gtk=no" "--with-gtk=3.0") \
+ $(use_with upnp) \
+ --without-openal \
+ --disable-autoupdate
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ emake -C docs
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if ! use dedicated; then
+ newgamesbin "${FILESDIR}"/${PN}-wrapper-script.sh ${PN}
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+ fi
+ use doc && dohtml -r docs/online/*
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}