summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-15 06:04:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-15 06:04:54 +0000
commitfb338d01236d28df05b5c8bc403670337f9033ae (patch)
tree7b695d4ff39cb6a66c2c72254ffc4739e5551f7f /games-action/trackballs/trackballs-1.1.1.ebuild
parentRemove obsolete versions. Mark version 0.6.8 stable on x86. Version bump (#11... (diff)
downloadgentoo-2-fb338d01236d28df05b5c8bc403670337f9033ae.tar.gz
gentoo-2-fb338d01236d28df05b5c8bc403670337f9033ae.tar.bz2
gentoo-2-fb338d01236d28df05b5c8bc403670337f9033ae.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-action/trackballs/trackballs-1.1.1.ebuild')
-rw-r--r--games-action/trackballs/trackballs-1.1.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-action/trackballs/trackballs-1.1.1.ebuild b/games-action/trackballs/trackballs-1.1.1.ebuild
new file mode 100644
index 000000000000..a2f2c7d9d65d
--- /dev/null
+++ b/games-action/trackballs/trackballs-1.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.1.1.ebuild,v 1.1 2005/11/15 06:04:54 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="simple game similar to the classical game Marble Madness"
+HOMEPAGE="http://trackballs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-music-1.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ >=dev-util/guile-1.6
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/icons//' share/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ src/Makefile.in \
+ po/Makefile.in.in \
+ || die "sed failed"
+ epatch "${FILESDIR}/${P}-localedir.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-highscores=${GAMES_STATEDIR}/${PN}-highscores \
+ $(use_enable nls) \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto "${GAMES_DATADIR}/${PN}/music"
+ doins "${WORKDIR}"/tb_*.ogg || die "doins failed"
+ dodoc AUTHORS ChangeLog README* NEWS
+ doicon share/icons/*png || die "doicon failed"
+ make_desktop_entry trackballs "Trackballs" trackballs-48x48.png
+ prepgamesdirs
+}