summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-16 01:51:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-16 01:51:14 +0000
commit60b503954cf37a9c5d0f51f734e174076c29b079 (patch)
tree71341dcf142367d3e328e0235487ef89cd38016b /games-action/violetland
parentadd >=www-plugins/adobe-flash-10.3.181.14 to package.mask for no-multilib users (diff)
downloadgentoo-2-60b503954cf37a9c5d0f51f734e174076c29b079.tar.gz
gentoo-2-60b503954cf37a9c5d0f51f734e174076c29b079.tar.bz2
gentoo-2-60b503954cf37a9c5d0f51f734e174076c29b079.zip
version bump (bug #364937)
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action/violetland')
-rw-r--r--games-action/violetland/ChangeLog8
-rw-r--r--games-action/violetland/violetland-0.4.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index e3bdc9f41ebe..5383da0a45fb 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.16 2011/05/06 16:36:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.17 2011/05/16 01:51:14 mr_bones_ Exp $
+
+*violetland-0.4.0 (16 May 2011)
+
+ 16 May 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.4.0.ebuild:
+ version bump (bug #364937)
*violetland-0.3.2 (06 May 2011)
diff --git a/games-action/violetland/violetland-0.4.0.ebuild b/games-action/violetland/violetland-0.4.0.ebuild
new file mode 100644
index 000000000000..79d58f59328b
--- /dev/null
+++ b/games-action/violetland/violetland-0.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.0.ebuild,v 1.1 2011/05/16 01:51:14 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ dev-libs/boost
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}