summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-04 03:28:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-04 03:28:15 +0000
commit01ad0cd4ad2234a44d5cc9fb2eb5dea5908bc810 (patch)
treeb792d9487a5837a40e68f856a7eb7304e325d216 /games-action
parentStable on amd64, bug #214301 (diff)
downloadgentoo-2-01ad0cd4ad2234a44d5cc9fb2eb5dea5908bc810.tar.gz
gentoo-2-01ad0cd4ad2234a44d5cc9fb2eb5dea5908bc810.tar.bz2
gentoo-2-01ad0cd4ad2234a44d5cc9fb2eb5dea5908bc810.zip
initial commit
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/wordwarvi/ChangeLog10
-rw-r--r--games-action/wordwarvi/Manifest4
-rw-r--r--games-action/wordwarvi/metadata.xml5
-rw-r--r--games-action/wordwarvi/wordwarvi-0.22.ebuild55
4 files changed, 74 insertions, 0 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
new file mode 100644
index 000000000000..1736dfaaffd7
--- /dev/null
+++ b/games-action/wordwarvi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/wordwarvi
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.1 2008/08/04 03:28:15 mr_bones_ Exp $
+
+*wordwarvi-0.22 (04 Aug 2008)
+
+ 04 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +wordwarvi-0.22.ebuild:
+ initial commit
+
diff --git a/games-action/wordwarvi/Manifest b/games-action/wordwarvi/Manifest
new file mode 100644
index 000000000000..46d514f93a85
--- /dev/null
+++ b/games-action/wordwarvi/Manifest
@@ -0,0 +1,4 @@
+DIST wordwarvi-0.22.tar.gz 6415648 RMD160 ef04e94736db2f7c4013c76d1adea086266bc953 SHA1 92dc55745e201a8ef88cd4ab0c033d2a10b4921e SHA256 0688828ea7da0e2df307685ca90de74f3dd2de1b8823c1d594dd9f1f40aaaad0
+EBUILD wordwarvi-0.22.ebuild 1392 RMD160 4dd3e96610b3973972a3e80b59b03709c176c8b8 SHA1 59c4d7a4a5b200ea2b50ea0aeedda846bb80e197 SHA256 d75de8011863bf157ddbf9dcd30378edccadf101a20e44446f85b891b9b0572c
+MISC ChangeLog 268 RMD160 7816725ffc077de364b9d81869f76fbecc36d322 SHA1 273579b9cb3eeb9bdbfa0d39f3177667a80488a5 SHA256 c1bc75113cb42940740eb63227e615310546402a837285123ffc71a2784e4370
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-action/wordwarvi/metadata.xml b/games-action/wordwarvi/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/wordwarvi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/wordwarvi/wordwarvi-0.22.ebuild b/games-action/wordwarvi/wordwarvi-0.22.ebuild
new file mode 100644
index 000000000000..6413f5e948e9
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-0.22.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-0.22.ebuild,v 1.1 2008/08/04 03:28:15 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis"
+
+RDEPEND="x11-libs/gtk+:2
+ vorbis? ( media-libs/libvorbis
+ >=media-libs/portaudio-0.19 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^DATADIR/s/=/?=/' \
+ -e '/^OPTIMIZE_FLAG/s/=.*/=$(CFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ install || die "emake install failed"
+ use vorbis || rm -rf "${D}${GAMES_DATADIR}/${PN}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}