summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 21:29:02 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 21:29:02 +0000
commit30f41cad37c902e7ca9364cf72ce1f41c5014a51 (patch)
treec302c83b3cf2dd902e19fdc287e44219490528f0 /games-action
parentadd subversion 1.5 use flags (diff)
downloadgentoo-2-30f41cad37c902e7ca9364cf72ce1f41c5014a51.tar.gz
gentoo-2-30f41cad37c902e7ca9364cf72ce1f41c5014a51.tar.bz2
gentoo-2-30f41cad37c902e7ca9364cf72ce1f41c5014a51.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/poopmup/ChangeLog8
-rw-r--r--games-action/poopmup/files/poopmup-1.2-gcc43.patch42
-rw-r--r--games-action/poopmup/poopmup-1.2.ebuild10
3 files changed, 54 insertions, 6 deletions
diff --git a/games-action/poopmup/ChangeLog b/games-action/poopmup/ChangeLog
index 3cefe7644f63..37e3d7d471e1 100644
--- a/games-action/poopmup/ChangeLog
+++ b/games-action/poopmup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/poopmup
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/ChangeLog,v 1.12 2007/06/13 15:16:52 nyhm Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/ChangeLog,v 1.13 2008/04/30 21:29:02 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/poopmup-1.2-gcc43.patch, poopmup-1.2.ebuild:
+ Fix building with gcc-4.3
13 Jun 2007; Tristan Heaven <nyhm@gentoo.org> poopmup-1.2.ebuild:
RESTRICT="test"
diff --git a/games-action/poopmup/files/poopmup-1.2-gcc43.patch b/games-action/poopmup/files/poopmup-1.2-gcc43.patch
new file mode 100644
index 000000000000..da4a455673a4
--- /dev/null
+++ b/games-action/poopmup/files/poopmup-1.2-gcc43.patch
@@ -0,0 +1,42 @@
+--- common.h
++++ common.h
+@@ -38,7 +38,7 @@
+ #define STDCALL
+ #endif
+
+-#include <iostream.h>
++#include <iostream>
+ #include "includes/base/myDisplayLists.h"
+ #include "myTimeStats.h"
+
+--- includes/base/myMatrix.h
++++ includes/base/myMatrix.h
+@@ -57,7 +57,7 @@
+ #include "my3dPoint.h"
+ #include "myVector.h"
+
+-#include <iostream.h>
++#include <iostream>
+ #include <math.h>
+
+ /**
+--- includes/osd/menu.h
++++ includes/osd/menu.h
+@@ -21,6 +21,7 @@
+ #define POOPMUP_MENU_H
+
+ #include <stdio.h>
++#include <cstring>
+ #include "../base/myColor.h"
+ #include "formElem/button.h"
+ #include "formElem/intSelector.h"
+--- includes/osd/onScreenDisplay.h
++++ includes/osd/onScreenDisplay.h
+@@ -21,6 +21,7 @@
+ #define ONSCREENDISPLAY_H
+
+ #include <stdio.h>
++#include <cstring>
+ #include "../base/my3dPoint.h"
+ #include "../base/myColor.h"
+
diff --git a/games-action/poopmup/poopmup-1.2.ebuild b/games-action/poopmup/poopmup-1.2.ebuild
index 4845f75b7468..169fd1eebb5e 100644
--- a/games-action/poopmup/poopmup-1.2.ebuild
+++ b/games-action/poopmup/poopmup-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.15 2007/06/13 15:16:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.16 2008/04/30 21:29:02 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -34,8 +34,10 @@ src_unpack() {
-e '/clear/d' \
Makefile || die "sed failed" # bug #120907
- epatch "${FILESDIR}/${P}-freeglut.patch"
- rm -rf $(find -name CVS)
+ epatch \
+ "${FILESDIR}"/${P}-freeglut.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ ecvs_clean
}
src_compile() {