summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 10:05:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 10:05:47 +0000
commit3c3ab45910e9f492b3a78a355b2460ff2891f986 (patch)
tree74aef93bc493acc2a8dd8ceb3134d749f3237ac3 /games-action
parentMasked media-gfx/kimdaba. Bug #145697. (diff)
downloadgentoo-2-3c3ab45910e9f492b3a78a355b2460ff2891f986.tar.gz
gentoo-2-3c3ab45910e9f492b3a78a355b2460ff2891f986.tar.bz2
gentoo-2-3c3ab45910e9f492b3a78a355b2460ff2891f986.zip
add RESTRICT="strip"; fix typo; error check install
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/mutantstorm-demo/ChangeLog6
-rw-r--r--games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.332
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild9
3 files changed, 12 insertions, 5 deletions
diff --git a/games-action/mutantstorm-demo/ChangeLog b/games-action/mutantstorm-demo/ChangeLog
index d6b55dd838f8..02b26247b262 100644
--- a/games-action/mutantstorm-demo/ChangeLog
+++ b/games-action/mutantstorm-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/mutantstorm-demo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.9 2006/01/10 23:07:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.10 2006/09/02 10:05:47 mr_bones_ Exp $
+
+ 02 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ mutantstorm-demo-1.33.ebuild:
+ add RESTRICT="strip"; fix typo; error check install
10 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
mutantstorm-demo-1.33.ebuild:
diff --git a/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33 b/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33
index 241e2d1dc0dd..486612d9284a 100644
--- a/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33
+++ b/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33
@@ -1 +1,3 @@
MD5 63aa5595bd04eeef5bd789fc782db122 MutantStormDemo_1_33.sh.bin 9249167
+RMD160 372919bce40babea6e8489b7ca64da1f5df1c2cb MutantStormDemo_1_33.sh.bin 9249167
+SHA256 d1afce2b73a8adbef445ba60632163d499850498c430aa14d39377812e4f3561 MutantStormDemo_1_33.sh.bin 9249167
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
index ef7ae0da5d1f..5f2984e04deb 100644
--- a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.8 2006/07/17 04:39:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.9 2006/09/02 10:05:47 mr_bones_ Exp $
inherit eutils games
@@ -12,6 +12,7 @@ LICENSE="POMPOM"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
+RESTRICT="strip"
RDEPEND="virtual/opengl
amd64? (
@@ -37,17 +38,17 @@ src_unpack() {
src_install() {
insinto "${dir}"
- doins -r menu script styles "${dir}"
+ doins -r menu script styles || die "doins failed"
exeinto "${dir}"
- doexe bin/Linux/x86/*
+ doexe bin/Linux/x86/* || die "doexe failed"
# Remove libSDL since we use the system version and our version doesn't
# have TEXTRELs in it.
rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
games_make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
insinto "${dir}"
- doins README.txt buy_me mutant.xpm pompom readme.htm
+ doins README.txt buy_me mutant.xpm pompom readme.htm || die "doins failed"
prepgamesdirs
}