summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-13 16:22:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-13 16:22:28 +0000
commit702d4a81deb3a99c9cc3dd5897e2c6718f496bec (patch)
tree447e0cd6a327952599d9aaaef4589859494a6b27 /games-action
parentalpha stable wrt #159269 (diff)
downloadgentoo-2-702d4a81deb3a99c9cc3dd5897e2c6718f496bec.tar.gz
gentoo-2-702d4a81deb3a99c9cc3dd5897e2c6718f496bec.tar.bz2
gentoo-2-702d4a81deb3a99c9cc3dd5897e2c6718f496bec.zip
Install cfg into GAMES_SYSCONFDIR; compile fix for new libggi version
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/koth/ChangeLog7
-rw-r--r--games-action/koth/koth-0.8.0.ebuild25
2 files changed, 21 insertions, 11 deletions
diff --git a/games-action/koth/ChangeLog b/games-action/koth/ChangeLog
index e454316f6a9c..8ac255253622 100644
--- a/games-action/koth/ChangeLog
+++ b/games-action/koth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/koth
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/ChangeLog,v 1.12 2005/06/15 17:31:31 wolf31o2 Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/ChangeLog,v 1.13 2007/06/13 16:22:28 nyhm Exp $
+
+ 13 Jun 2007; Tristan Heaven <nyhm@gentoo.org> koth-0.8.0.ebuild:
+ Install cfg into GAMES_SYSCONFDIR; compile fix for new libggi version
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> koth-0.7.7.ebuild,
koth-0.8.0.ebuild:
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index 0ebf7e264622..9297a2d1dfdf 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation and Arcady Genkin <agenkin@thpoon.com>
+# Copyright 1999-2007 Gentoo Foundation and Arcady Genkin <agenkin@thpoon.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.13 2005/06/15 17:31:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.14 2007/06/13 16:22:28 nyhm Exp $
inherit eutils games
@@ -15,16 +15,23 @@ IUSE=""
DEPEND="media-libs/libggi"
-src_unpack(){
- unpack ${A}
- cd ${S}/src
- epatch ${FILESDIR}/koth-0.8.0-gcc-3.4.patch
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -i 's:-g -O2::' configure \
+ || die "sed configure failed"
+ cd src
+ epatch "${FILESDIR}"/${P}-gcc-3.4.patch
+ sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h \
+ || die "sed cfgfile.h failed"
+ sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h \
+ || die "sed gfx.c gfx.h failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- insinto /etc/koth
- doins src/koth.cfg
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_SYSCONFDIR}"
+ doins src/koth.cfg || die "doins failed"
dodoc AUTHORS ChangeLog NEWS README doc/*.txt
prepgamesdirs
}